summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormosquito2023-03-15 19:32:55 +0800
committermosquito2023-03-15 19:32:55 +0800
commit2c67d9e5383400f868cda6a1bac9f60a158f8e3c (patch)
treec708c68edc039db3ef4ea5fb3bd53279f67fd2fa /PKGBUILD
downloadaur-2c67d9e5383400f868cda6a1bac9f60a158f8e3c.tar.gz
upload to aur.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69b202e52762
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: mosquito <mosquito@email.cn>
+pkgname=bobibo
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A cli-app, convert pictures to ascii arts."
+arch=("x86_64")
+url="https://github.com/orzation/bobibo"
+license=('GPL3')
+makedepends=('go>=1.17' 'upx')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/orzation/bobibo/archive/v${pkgver}.tar.gz")
+sha256sums=('8aba2b783c8d6812ba893d8ac9fb867b74796d9df9f2a22cfd3aadface4f0eb8')
+
+optdepends=(
+ 'sudo: privilege elevation'
+ 'doas: privilege elevation'
+)
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_ENABLED=1
+
+ cd "$srcdir/$pkgname-$pkgver/cli"
+ make build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/cli"
+ make DESTDIR="$pkgdir" install
+}