summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Hill2020-04-06 20:38:17 -0500
committerAndrew Hill2020-04-06 20:38:17 -0500
commit71d626dacf8380c4cec2d120e35f6a9944c4ce9d (patch)
tree2039aedde315e1773b0d0149ef977c076b729efb /PKGBUILD
downloadaur-71d626dacf8380c4cec2d120e35f6a9944c4ce9d.tar.gz
Initial commit (except not really I had to remake the repo to get AUR to work
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fb9682ad57c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andrew Hill <andrew@andrewkhill.com>
+pkgname=bok
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf $(git describe | sed "s/-/./g")
+}
+pkgver=v1.0.1.g9cc54d9
+pkgrel=1
+pkgdesc="A simple shellscript to manage personal journals"
+arch=('any')
+url="https://github.com/astroengisci/bok"
+license=('GPL')
+depends=('sh')
+makedepends=('git')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("git+$url")
+md5sums=('SKIP') #autofill using updpkgsums
+
+package() {
+ cd "$pkgname"
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" -s install
+}