summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmilio Reggi2020-12-04 19:47:04 +0100
committerEmilio Reggi2020-12-04 19:47:04 +0100
commitfd4cbc84d2b81722de802954c3c1d112a788a398 (patch)
tree609b131bad7ef7a332e1a01e9f343847d79ce70a /PKGBUILD
parent75fb7f2c79d497ba300289e36183c1c9641e82a9 (diff)
downloadaur-fd4cbc84d2b81722de802954c3c1d112a788a398.tar.gz
Added proper go flags to PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c8a0bf0977a..29464bb0868a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,11 @@ pkgver() {
build() {
cd "$_pkgname"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
make PREFIX=/usr
}