summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOlivier Biesmans2016-06-25 00:45:08 +1000
committerOlivier Biesmans2016-06-25 00:45:08 +1000
commit2b8d69b96b1350488173ca04fc9bdb456ef8357f (patch)
treeb5ee04d3aa577e653bc587a08665ed8211ed74b3 /PKGBUILD
downloadaur-2b8d69b96b1350488173ca04fc9bdb456ef8357f.tar.gz
Package bombardier 0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c49000aec507
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Olivier Biesmans <o.archlinux@biesmans.fr>
+
+pkgname=bombardier
+pkgver=0.2
+pkgrel=1
+pkgdesc="Crossplatform HTTP benchmarking tool written in Go"
+arch=('x86_64' 'i686')
+url="https://github.com/codesenberg/bombardier"
+license=('MIT')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=("https://github.com/codesenberg/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('2ddec6bc421a8688ae388c57bf59183eacac71cb82ac2f3cfda58951cd11ae51')
+
+build() {
+ mkdir -p gopath/src
+ mv "$pkgname-$pkgver" "gopath/src/$pkgname"
+ GOPATH="$(pwd)/gopath" go build -o "$srcdir/build/$pkgname" "$pkgname"
+ echo $(pwd)
+}
+
+package() {
+ install -Dm755 "$srcdir/build/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/gopath/src/$pkgname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: