summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-05-31 04:47:46 -0400
committerPatrick Northon2021-05-31 04:47:46 -0400
commit50681f33aa6735d0ea6998351ff3a308a81144ae (patch)
tree9809a57325c8e99f8f3f983d0449b7dd73a1b2b1 /PKGBUILD
parentbdd0fe76982c568f111462f475803b7bebb36b03 (diff)
downloadaur-50681f33aa6735d0ea6998351ff3a308a81144ae.tar.gz
Update 151 levels pack url and fix -Werror=format-security error.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7378bb4094d2..a2ea48661517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: Micael Soder <zoulnix@gmail.com>
pkgname=bombermaaan
pkgver=1.4.0.627
-pkgrel=5
+pkgrel=6
_pkgdate=20081018
pkgdesc="A classic Bomberman-like game with multiplayer support"
arch=('i686' 'x86_64')
@@ -14,36 +15,40 @@ depends=('sdl_mixer')
install=$pkgname.install
source=("http://downloads.sourceforge.net/$pkgname/Bombermaaan_${pkgver}_${_pkgdate}_src.tar.gz"
"http://downloads.sourceforge.net/$pkgname/Bombermaaan_${pkgver}_${_pkgdate}_res.tar.gz"
- "http://media1.gamefront.com/moddb/2011/02/17/Bombermaan_levels_pack.zip"
+ "https://www.moddb.com/downloads/mirror/30444/123/0ae43028077e624538aa4e1d3820190d"
"$pkgname.png"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ "print.patch")
sha256sums=('fb0b6d59569d436ac10b452857b8800b831513ab888b29a66c2dc0ada12d045d'
'48c702d42a87b44606cbed2da88b49b250f66c6a65067d1dc43b25980ef1c74a'
'7a73655f609096271434d20e8a9c33b9af71c547a4a1fc312fbd85866f6c8519'
'803576f10eb6b45e807cd12a4ccd6b17652ddda53bf8f0e2fa1fb5623d9287bc'
- '06f8be98170c3c95628003a1419bb25527617330f225bab82baffa564ca1f92b')
+ '06f8be98170c3c95628003a1419bb25527617330f225bab82baffa564ca1f92b'
+ 'b31241dc1f69c341479acfff6a145f5b0e41c7b5cdcc0d26ef9cd44543303a28')
prepare() {
- cd Bombermaaan_${pkgver}_${_pkgdate}_src
+ cd "Bombermaaan_${pkgver}_${_pkgdate}_src"
# copy data files for generated library
- cp -r ../Bombermaaan_${pkgver}_${_pkgdate}_res/RES32 .
+ cp -r "../Bombermaaan_${pkgver}_${_pkgdate}_res/RES32" .
- cd Bombermaaan
+ cd "Bombermaaan"
# type fix
sed "s|\tchar \*backslash|\tconst char \*backslash|" -i winreplace.cpp
# adapt directory to arch standards
sed "s|share/games/bombermaaan|share/bombermaaan|" -i CGame.cpp
# add our cflags/ldflags
sed "s|SDL_CFLAGS :=|& $CXXFLAGS |;s|SDL_LDFLAGS :=|& $LDFLAGS |" -i Makefile
+
+ patch -N -i "${srcdir}/print.patch"
}
build() {
- make -C Bombermaaan_${pkgver}_${_pkgdate}_src
+ make -C "Bombermaaan_${pkgver}_${_pkgdate}_src"
}
package() {
- cd Bombermaaan_${pkgver}_${_pkgdate}_src
+ cd "Bombermaaan_${pkgver}_${_pkgdate}_src"
# binary
install -Dm755 Bombermaaan/Bombermaaan "$pkgdir"/usr/bin/bombermaaan