summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTaegil Bae2017-12-19 00:19:43 +0900
committerTaegil Bae2017-12-19 00:19:43 +0900
commitc9ea0f977b213d3a732f3dcdbf3c0ffa28a4ff76 (patch)
tree7c4cefca736253af0287384b41da9c1026a28c10 /PKGBUILD
parent23bf486c3066c8352eb5d773bea413e79c61ef55 (diff)
downloadaur-c9ea0f977b213d3a732f3dcdbf3c0ffa28a4ff76.tar.gz
Added a patch for Qt 5.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 016635ab7bfc..3f8a1e55eb43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgbase=bomi
pkgname=$_pkgbase-git
-pkgver=0.9.11.r33.g2f3d7e4a
-pkgrel=1
+pkgver=0.9.11.r35.g6571d62f
+pkgrel=2
pkgdesc="Powerful and easy-to-use GUI multimedia player based on mpv (git version)"
arch=('i686' 'x86_64')
url="http://bomi-player.github.io"
@@ -25,8 +25,10 @@ optdepends=('libva-intel-driver: hardware acceleration support for Intel GPU'
'libbdplus: BD+ decryption for Blu-ray support')
provides=('bomi')
conflicts=('cmplayer' 'bomi')
-source=(git+https://github.com/d-s-x/${_pkgbase}.git)
-md5sums=('SKIP')
+source=(git+https://github.com/d-s-x/${_pkgbase}.git
+ qml_internal_types.patch)
+md5sums=('SKIP'
+ '965ead6202472215d8cb2d875584dfb7')
#options=(debug !strip)
pkgver() {
@@ -38,6 +40,11 @@ prepare() {
cd "$srcdir/$_pkgbase"
./configure --prefix=/usr
+
+ # Temporary fix until the upstream is fixed.
+ if ! grep PlayInfoText ./src/bomi/imports/bomi/qmldir; then
+ patch -p1 -i "$srcdir/qml_internal_types.patch"
+ fi
}
build() {