summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter2017-09-08 08:36:25 +0200
committerPeter2017-09-08 08:36:25 +0200
commitc35cc543b664491a74d73a52f57640544c905f76 (patch)
treeb8d5ab1af7293241ed8a6312ba8f8bea13e7fa37 /PKGBUILD
parent8f4e351d401a8370e389350f16a1df69930eaaed (diff)
downloadaur-c35cc543b664491a74d73a52f57640544c905f76.tar.gz
add -no-pie to linker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6864d987b5b1..5463d259bb3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: Peter <craven@gmx.net>
pkgname=bones
pkgver=20150929
-pkgrel=1
+pkgrel=2
pkgdesc="A simple Scheme compiler for x86_64 systems"
arch=(x86_64)
url="http://www.call-with-current-continuation.org/bones/"
@@ -31,7 +31,7 @@ validpgpkeys=()
build() {
cd "$pkgname-2015-09-29"
nasm -f elf64 bones-x86_64-linux.s -o bones.o
- gcc bones.o -o bones -lrt
+ gcc -no-pie bones.o -o bones -lrt
}
package() {