summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlois Nešpor2015-07-01 23:49:54 +0200
committerAlois Nešpor2015-07-01 23:49:54 +0200
commitcd68ba9a423ee3d0334cd4e751c99aad49d0f6ed (patch)
tree9bcdbde1246cc88e5f31bfc84f830e70916c4fd5 /PKGBUILD
downloadaur-cd68ba9a423ee3d0334cd4e751c99aad49d0f6ed.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a36d48d8ca63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alois Nespor <info@aloisnespor.info>
+
+pkgname=booksorg
+pkgver=0.1
+pkgrel=1
+pkgdesc="booksorg is a easy organizer for your PDF books using qpdfview and poppler library."
+arch=('i686' 'x86_64')
+url="http://booksorg.sourceforge.net"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('gcc')
+options=(!emptydirs)
+source=("http://downloads.sourceforge.net/$pkgname/${pkgname}_${pkgver}.tar.gz")
+
+
+build() {
+ cd $srcdir/${pkgname}_${pkgver}
+ qmake-qt5 booksorg.pro PREFIX="/usr" \
+ QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" \
+ QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" \
+ QMAKE_LFLAGS_RELEASE="$LDFLAGS"
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}_${pkgver}
+ make "INSTALL_ROOT=$pkgdir" install
+
+}
+sha256sums=('eeea945976f3c5515fba8952cd241826df12115c506bfd64879a0551cf139163')