summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Rys2024-01-16 14:12:31 +0100
committerMartin Rys2024-01-16 14:12:31 +0100
commit34d9ba7f2be7ff003833cbbcf6ea8ca4ca6f89fa (patch)
treead56e8d736c9416267d5b8ab2155f802e1533dcd /PKGBUILD
parent3636f9fffb938f1f758b58ca357cacbe204965ef (diff)
downloadaur-34d9ba7f2be7ff003833cbbcf6ea8ca4ca6f89fa.tar.gz
Fix building due to bad paths, add optdepends and move php-fpm there.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0c6514e4213..33233a7a3d8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
pkgname=bookstack
_camelname=BookStack
pkgver=23.12
-pkgrel=1
+pkgrel=2
pkgdesc='A simple, self-hosted, easy-to-use platform for organising and storing information'
arch=('any')
url="https://github.com/BookStackApp/BookStack"
license=('MIT')
+# https://www.bookstackapp.com/docs/admin/installation/
depends=(
'php'
'php-gd'
- 'php-fpm'
+)
+optdepends=(
+ 'php-apache: webserver and a PHP implementation'
+ 'php-fpm: fastCGI'
+ 'mariadb: database'
+ 'nginx: webserver'
)
makedepends=('composer')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/BookStackApp/BookStack/archive/v${pkgver}.tar.gz"
'bookstack.conf'
)
-sha256sums=(
- 'fce344f1c9257465826715861ea0e3d5b8648ad39edde7a24ecf3060cf86e0fe'
- '82152fc91366d1bd623c559c03240f070e08d45a084a4c6e2e211f671bee8c78'
-)
+sha256sums=('fce344f1c9257465826715861ea0e3d5b8648ad39edde7a24ecf3060cf86e0fe'
+ '82152fc91366d1bd623c559c03240f070e08d45a084a4c6e2e211f671bee8c78')
options=('!strip')
backup=("etc/webapps/$pkgname/config.env")
@@ -45,5 +49,5 @@ package() {
mv "$pkgdir/usr/share/webapps/$pkgname/storage" "$pkgdir/var/lib/$pkgname"
ln -s "/var/lib/$pkgname" "$pkgdir/usr/share/webapps/$pkgname/storage"
- install -Dm644 "${srcdir}/../bookstack.conf" "${pkgdir}/usr/lib/tmpfiles.d/bookstack.conf"
+ install -Dm644 "${srcdir}/bookstack.conf" "${pkgdir}/usr/lib/tmpfiles.d/bookstack.conf"
}