summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-11-30 16:36:21 +0100
committerMichel Zou2019-11-30 16:36:21 +0100
commitf4a67f7ae1b6fdc5df4d962365fdefbfea58175e (patch)
tree47fbe93b208a2d37b758ba93963031b43ace0547 /PKGBUILD
downloadaur-f4a67f7ae1b6fdc5df4d962365fdefbfea58175e.tar.gz
1.71
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78299384206c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=boost-stacktrace-backtrace
+pkgver=1.71.0
+_boostver=${pkgver//./_}
+pkgrel=1
+pkgdesc='Boost.stacktrace backtrace variant'
+url='https://www.boost.org/'
+arch=('x86_64')
+license=('custom')
+depends=('boost' 'libbacktrace-git')
+options=('staticlibs')
+provides=(libboost_stacktrace_backtrace.so)
+source=("https://dl.bintray.com/boostorg/release/${pkgver}/source/boost_${_boostver}.tar.bz2")
+sha256sums=('d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee')
+
+build() {
+ cd boost_${_boostver}
+ ./bootstrap.sh --with-toolset=gcc
+ ./b2 \
+ variant=release \
+ debug-symbols=off \
+ threading=multi \
+ runtime-link=shared \
+ link=shared,static \
+ toolset=gcc \
+ cflags="${CPPFLAGS} ${CFLAGS} -fPIC -O3" \
+ cxxflags="${CPPFLAGS} ${CXXFLAGS} -std=c++14 -fPIC -O3" \
+ linkflags="${LDFLAGS}" \
+ --layout=system \
+ --with-stacktrace
+}
+
+package() {
+ cd boost_${_boostver}
+ install -d "${pkgdir}"/usr/lib
+ cp -P stage/lib/libboost_stacktrace_backtrace.* "${pkgdir}"/usr/lib
+}