summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKamil Cukrowski2021-11-16 12:42:24 +0100
committerKamil Cukrowski2021-11-16 12:42:24 +0100
commitbc6e41fbb81ededda514e5406f1bee83e204c6a5 (patch)
treeaefc26ad9b334958a04656295505b96cb059153e /PKGBUILD
parent4732fa70b652c3d42aa3284b9aeb89be3bd83d23 (diff)
downloadaur-bc6e41fbb81ededda514e5406f1bee83e204c6a5.tar.gz
fix namcap problems
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b927439eab3..92db08c33a90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=boost-tool-wave-git
pkgver=2.0
pkgrel=1
-pkgdesc="The Wave Driver Executable"
-arch=(any)
-url="https://www.boost.org/doc/libs/1_76_0/libs/wave/"
+pkgdesc="Boost The Wave Driver Executable"
+arch=("x86_64")
+url="https://www.boost.org/doc/libs/1_77_0/libs/wave/"
license=(custom)
groups=()
-depends=(boost)
+depends=(boost-libs)
makedepends=(git)
optdepends=()
provides=()
@@ -16,17 +16,20 @@ conflicts=()
replaces=()
backup=()
options=()
-source=("git+https://github.com/boostorg/wave.git")
-md5sums=(SKIP)
+source=("git+https://github.com/boostorg/wave.git" 'https://www.boost.org/LICENSE_1_0.txt')
+md5sums=(SKIP e4224ccaecb14d942c71d31bef20d78c)
build() {
(
set -x
- g++ $CFLAGS ./wave/tool/cpp.cpp -lboost_thread -lboost_filesystem -lboost_wave -lboost_program_options -lboost_timer
+ g++ $CFLAGS ./wave/tool/cpp.cpp $LDFLAGS -lboost_thread -lboost_filesystem -lboost_wave -lboost_program_options -lboost_timer
)
}
package() {
install -d -m755 "$pkgdir"/usr/bin/
install -m755 ./a.out "$pkgdir"/usr/bin/wave
+
+ install -d -m755 "$pkgdir"/usr/share/licenses/boost-tool-wave-git
+ install -m644 -t "$pkgdir"/usr/share/licenses/boost-tool-wave-git/ ./LICENSE_1_0.txt
}