summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2015-05-01 18:56:29 +0200
committerVianney le Clément de Saint-Marcq2015-05-01 18:56:29 +0200
commit691140f9cb2008154826f01a33859c90988ca753 (patch)
tree1d75ab34cd9383b70601e6918704b8bd287fb382 /PKGBUILD
downloadaur-691140f9cb2008154826f01a33859c90988ca753.tar.gz
New package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18430843fe44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Vianney le Clément <vleclement AT gmail·com>
+_pkgname=bootimgtool
+pkgname=$_pkgname-git
+pkgver=20150501.g1c6e2bf
+pkgrel=1
+pkgdesc="Android boot.img extractor/assembler handling multiple variants"
+arch=('i686' 'x86_64')
+url="https://github.com/vianney/bootimgtool"
+license=('GPL3')
+depends=('openssl')
+makedepends=('git' 'autoconf' 'automake')
+source=("git://github.com/vianney/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ _date=$(git show -s --format='%ci' | cut -d' ' -f1 | sed 's/-//g')
+ _hash=$(git show -s --format='%h')
+ echo "$_date.g$_hash"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install DESTDIR="$pkgdir"
+}