summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorANDRoid78902022-07-23 22:08:22 +0400
committerANDRoid78902022-07-23 22:08:22 +0400
commit52336cd3967b16dff561efdbe9829e3a0ad21054 (patch)
tree36b56216c9db67fb74ac23e68ae3e101fe10f149 /PKGBUILD
downloadaur-52336cd3967b16dff561efdbe9829e3a0ad21054.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07f4ff80fe10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: ANDRoid7890 <andrey.android7890@gmail.com>
+
+pkgname=bootsplash-manager-git
+_pkgname=${pkgname//-git}
+pkgver=1.9.r0.g4f83103
+pkgrel=1
+pkgdesc="Simple bootsplash manager"
+url="https://github.com/ANDRoid7890/bootsplash-manager"
+arch=(x86_64)
+license=(GPL3)
+depends=('qt5-base'
+ 'bootsplash-systemd'
+ 'kauth'
+ 'pamac'
+ 'sdl2')
+conflicts=('bootsplash-manager-bin')
+
+source=("git+https://github.com/ANDRoid7890/bootsplash-manager.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}"
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+}