summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrey Alekseev2020-09-14 20:58:05 +0400
committerAndrey Alekseev2020-09-14 20:58:05 +0400
commit680213d95273c049800396d92a9beaf8a9a373dc (patch)
tree136ee2bb702ff0f335023597a821aeb78fc5a7ac /PKGBUILD
downloadaur-680213d95273c049800396d92a9beaf8a9a373dc.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4402b1bff092
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrey Alekseev <andrey.android7890@gmail.com>
+
+pkgname=('bootsplash-theme-manjaro-space-purple-git')
+pkgver=1.0.r13.g1c6189d
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Beautiful Manjaro Bootsplash with space animation"
+url="https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-purple"
+license=('GPL')
+depends=()
+optdepends=('bootsplash-systemd: for bootsplash functionality')
+makedepends=('imagemagick')
+source=('git+https://github.com/ANDRoid7890/bootsplash-theme-manjaro-space-purple.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "bootsplash-theme-manjaro-space-purple"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir"/"bootsplash-theme-manjaro-space-purple"
+ sh ./bootsplash-manjaro-space.sh
+}
+
+package() {
+ pkgdesc="Beautiful Manjaro Bootsplash with space animation"
+ cd "$srcdir"
+
+ install -Dm644 "$srcdir/bootsplash-theme-manjaro-space-purple/bootsplash-manjaro-space-purple" "$pkgdir/usr/lib/firmware/bootsplash-themes/manjaro-space-purple/bootsplash"
+ install -Dm644 "$srcdir/bootsplash-theme-manjaro-space-purple/bootsplash-manjaro-space-purple.initcpio_install" "$pkgdir/usr/lib/initcpio/install/bootsplash-manjaro-space-purple"
+}