summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-11-05 00:35:39 +0800
committerChocobo12023-11-05 00:35:39 +0800
commit811bf8e9409fa7398026189daa8af899669f97f4 (patch)
tree99e1081ac18b5dcb60eca026e5ccad58899474af /PKGBUILD
parentc866af05b16d2f511e4e3dd1fea1af1ace460bd1 (diff)
downloadaur-811bf8e9409fa7398026189daa8af899669f97f4.tar.gz
upgpkg: bootstrap-dht-git r131.g679c661-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 525fa2f7053c..3d92ca6bc3d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=bootstrap-dht-git
-pkgver=r122.679c661
-pkgrel=3
+pkgver=r131.g679c661
+pkgrel=1
pkgdesc="Bittorrent DHT bootstrap server"
arch=('i686' 'x86_64')
url="https://github.com/bittorrent/bootstrap-dht"
@@ -26,7 +26,9 @@ prepare() {
pkgver() {
cd "bootstrap-dht"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
}
build() {