summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12021-09-18 18:05:50 +0800
committerChocobo12021-09-18 18:15:48 +0800
commitdbf6feadcb1f9d1edf6e0a06861eb86d2c71586f (patch)
treeef3a003003382c3da94939bd32be5b2112fa68dc /PKGBUILD
parent800e0aab0ee2cef8ea13c0390e7f62aa75a6a2a8 (diff)
downloadaur-dbf6feadcb1f9d1edf6e0a06861eb86d2c71586f.tar.gz
upgpkg: bootstrap-dht-git r122.679c661-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cea45f8921f4..9d688bfa014e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,27 @@
pkgname=bootstrap-dht-git
pkgver=r122.679c661
-pkgrel=1
+pkgrel=2
pkgdesc="Bittorrent DHT bootstrap server"
arch=('i686' 'x86_64')
url="https://github.com/bittorrent/bootstrap-dht"
license=('MIT')
depends=('glibc' 'boost-libs')
-makedepends=('git' 'boost-build')
+makedepends=('git' 'boost')
provides=('bootstrap-dht')
conflicts=('bootstrap-dht')
-source=("git+https://github.com/bittorrent/bootstrap-dht.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/bittorrent/bootstrap-dht.git"
+ "boost.patch::https://github.com/bittorrent/bootstrap-dht/commit/131e4d2caccc227afa62837899123f424dccb296.patch")
+sha256sums=('SKIP'
+ '2984970318c71910e1e23093564f5048f9311ed0d4d16d1ef5623e9f9b86f331')
+prepare() {
+ cd "bootstrap-dht"
+
+ patch -Np1 -i "$srcdir/boost.patch"
+}
+
pkgver() {
cd "bootstrap-dht"
@@ -24,20 +32,26 @@ pkgver() {
build() {
cd "bootstrap-dht"
- b2 "$MAKEFLAGS" release
+ b2 \
+ cflags="$CFLAGS" \
+ cxxflags="$CXXFLAGS" \
+ linkflags="$LDFLAGS" \
+ release
}
check() {
cd "bootstrap-dht/tests"
- b2 "$MAKEFLAGS" release
+ b2 \
+ cflags="$CFLAGS" \
+ cxxflags="$CXXFLAGS" \
+ linkflags="$LDFLAGS" \
+ release
}
package() {
cd "bootstrap-dht"
- install -d "$pkgdir/usr/bin/"
- install -m755 "dht-bootstrap" "$pkgdir/usr/bin/"
-
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/bootstrap-dht/LICENSE"
+ install -Dm755 "dht-bootstrap" -t "$pkgdir/usr/bin"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/bootstrap-dht"
}