summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorquininer2019-03-27 23:37:15 +0800
committerquininer2019-03-27 23:37:15 +0800
commit94793e4552f79dcf40a636fb0ac796eb69f2dfb1 (patch)
tree2f701ec4d7e946114d3f65589b5c82d4c7341bc6 /PKGBUILD
downloadaur-94793e4552f79dcf40a636fb0ac796eb69f2dfb1.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01b0935ecfba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=boringtun-git
+pkgver=0.2.0.9.g201682d
+pkgrel=1
+pkgdesc="Userspace WireGuard® Implementation in Rust"
+arch=('x86_64' 'i686')
+url="https://github.com/cloudflare/boringtun"
+license=('BSD-3-Clause')
+depends=()
+makedepends=('cargo' 'git')
+optdepends=()
+provides=('boringtun')
+conflicts=('boringtun')
+source=($pkgname::git+https://github.com/cloudflare/boringtun)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/boringtun" "$pkgdir/usr/bin/boringtun"
+}