summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Vybíhal2021-10-07 16:16:40 +0200
committerJosef Vybíhal2021-10-07 16:16:40 +0200
commitdace497e375e7a33566fd4db50bcb292683c57ab (patch)
treef611d588354fa11f93d664ed6d878f4d7c48fb98 /PKGBUILD
downloadaur-dace497e375e7a33566fd4db50bcb292683c57ab.tar.gz
newpkg: boundary-desktop 1.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..722b531d7cee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Josef Vybíhal <josef.vybihal@gmail.com>
+
+pkgname=boundary-desktop
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Desktop Client for Boundary"
+arch=('x86_64')
+url="https://releases.hashicorp.com/boundary-desktop/${pkgver}/${pkgname}_${pkgver}_linux_amd64.deb"
+license=('MPL-2.0')
+depends=("gtk3" "libnotify" "nss" "libxtst" "xdg-utils" "at-spi2-core" "libdrm" "mesa" "libxcb" "gvfs" "glib2")
+#FIXME: optdepends=("org.freedesktop.secrets")
+# Recommends: pulseaudio | libasound2
+# Suggests: gir1.2-gnomekeyring-1.0, libgnome-keyring0, lsb-release
+source=("${pkgname}_${pkgver}_linux_amd64.deb::https://releases.hashicorp.com/boundary-desktop/${pkgver}/${pkgname}_${pkgver}_linux_amd64.deb")
+sha256sums=('96a63d9379eb8e470a59973f4e30817f13f8c0a7d7e38018f1011b0818a321fb')
+
+package() {
+ msg2 "Extracting the data.tar.xz"
+ tar -xf data.tar.xz -C "${pkgdir}/"
+
+ # .deb has 775
+ cd ${pkgdir}
+ chmod 755 ${pkgdir}/usr
+ chmod 755 ${pkgdir}/usr/*
+ chmod 755 ${pkgdir}/usr/share/*
+}