summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorber532k2017-07-29 22:56:50 +0200
committerber532k2017-07-29 22:56:50 +0200
commitd58a8e19db118c34662e8552f05fcd97c7a47e00 (patch)
tree50f7ee01f9733c58ebe2a0e51344062f5efe8955 /PKGBUILD
downloadaur-d58a8e19db118c34662e8552f05fcd97c7a47e00.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73fd150800fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ber532k <ber532k@gmx.de>
+pkgname=bower-mail
+pkgver=0.7
+pkgrel=1
+pkgdesc="A curses terminal client for the Notmuch email system"
+arch=('any')
+url="https://github.com/wangp/bower"
+depends=('notmuch' 'ncurses' 'coreutils' 'file' 'mercury>=11.07')
+makedepends=('gpgme')
+optdepends=('msmtp: send messages' 'lynx: dump HTML emails' 'w3m: dump HTML emails')
+conflicts=('bower')
+license=('GPL3')
+source=("https://github.com/wangp/bower/archive/$pkgver.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ patch $srcdir/bower-$pkgver/src/Mercury.options < ../arch.patch
+ cd $srcdir/bower-$pkgver
+ make PARALLEL=$MAKEFLAGS
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m 755 $srcdir/bower-$pkgver/bower $pkgdir/usr/bin/
+}