summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-11 14:03:20 +0000
committerGrey Christoforo2017-03-11 14:03:20 +0000
commit1ab892ea5a1a9ab6dd8499868b46ad2108ce99ff (patch)
tree8690de6d1c56d151cac860eaa452ee8cbf59ec4e /PKGBUILD
parent413591a7b1b8222e5b8d1cfd53e3149aedca2f54 (diff)
downloadaur-1ab892ea5a1a9ab6dd8499868b46ad2108ce99ff.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 934c4dc4e2aa..9540e89f3be6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=bowtie2
-pkgver=2.2.9
+pkgver=2.3.1
pkgrel=1
pkgdesc="Bowtie 2 is an ultrafast and memory-efficient tool for aligning sequencing reads to long reference sequence."
arch=("any")
+depends=('termcap')
optdepends=('intel-tbb: faster multithreading')
url="http://bowtie-bio.sourceforge.net/bowtie2"
license=('GPL3')
source=("https://github.com/BenLangmead/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('168bdcd6a648e96d8a9a854cdbae24d8')
+md5sums=('537d24b27a90677bbc54b970da5b597e')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -22,17 +23,17 @@ build() {
if pacman -Q intel-tbb > /dev/null 2>/dev/null; then
#msg2 "Building with Intel's TBB multithreading support"
#WITH_TBB=1 make prefix=/usr
- # tbb is broken in this release...remove this when fixed
- WITH_TBB=0 make
+ # tbb is _STILL_ broken in this release...remove this when fixed
+ NO_TBB=1 make prefix=/usr
else
msg2 "You haven't installed the intel-tbb package; building without Intel's TBB multithreading support"
- WITH_TBB=0 make
+ NO_TBB=1 make
fi
}
package() {
- mkdir -p "${pkgdir}/opt/${pkgname}"
- cp -a "${srcdir}/${pkgname}-${pkgver}"/* "${pkgdir}/opt/${pkgname}"/.
+ mkdir -p "${pkgdir}/opt/"
+ cp -a "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/opt/${pkgname}"
cd "${srcdir}/${pkgname}-${pkgver}"
make prefix=/usr DESTDIR="${pkgdir}" install
install -Dm644 ${srcdir}/${pkgname}-${pkgver}/MANUAL -t "${pkgdir}/usr/share/doc/${pkgname}"