summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuldeep Singh Dhaka2016-12-25 18:32:18 +0530
committerKuldeep Singh Dhaka2016-12-25 18:42:21 +0530
commit543c8bb7edd66a74aad14a578fa5a94542298ced (patch)
treeb4d1508783bf8d6993f8586aa987dd487d07e195 /PKGBUILD
parent7b0650e73d9f3f8dd5c5d9bfa3d9b090f3b81072 (diff)
downloadaur-543c8bb7edd66a74aad14a578fa5a94542298ced.tar.gz
Generate PNG icon from SVG
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6af11329795..3d696f38168b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=box0-studio-qt-git
_pkgname=box0-studio-qt
-pkgver=142.9a951c1
+pkgver=145.661f50f
pkgrel=1
pkgdesc="Box0 Studio is the Common Instruments software for Box0"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ conflicts=(box0-studio-qt)
replaces=(box0-studio-qt)
source=("git+https://gitlab.com/madresistor/$_pkgname.git" "box0-studio.desktop")
depends=('fftw' 'libbox0' 'libreplot' 'lmfit' 'muparser' 'qt5-base' 'qt5-svg' 'adwaita-icon-theme')
-makedepends=('cmake' 'git')
+makedepends=('cmake' 'git' 'imagemagick')
md5sums=('SKIP' "6454ffd649c576a16397b7d9522848b0")
@@ -31,14 +31,17 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname/build"
+ cd "$srcdir"
+ convert -background none "$_pkgname/src/res/app_icon/app_icon.svg" app_icon.png
+
+ cd "$_pkgname/build"
cmake -DCMAKE_INSTALL_PREFIX='/usr' -DUSE_MULTI_PROC='TRUE' ..
make
}
package() {
#desktop file and icon
- install -Dm644 $srcdir/$_pkgname/src/res/app_icon/app_icon.png "$pkgdir/usr/share/pixmaps/box0-studio.png"
+ install -Dm644 "$srcdir/app_icon.png" "$pkgdir/usr/share/pixmaps/box0-studio.png"
install -Dm644 box0-studio.desktop "$pkgdir/usr/share/applications/box0-studio.desktop"
make -C "$srcdir/$_pkgname/build" DESTDIR="${pkgdir}" install