summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2019-08-06 02:05:51 +0200
committerFrederik “Freso” S. Olesen2019-08-06 02:05:51 +0200
commit2a503ec9125fefb064cc660d51d3319e895c5aaf (patch)
tree8b21787e6e44c51053692517574e23a5612bc5b5 /PKGBUILD
parent9552a893cb28b0ab824f5144f93ae05f064f67bf (diff)
downloadaur-2a503ec9125fefb064cc660d51d3319e895c5aaf.tar.gz
boxtron-git 0.5.0.r2.e4bf54e-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 28 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eb0c5f5f4ab..8935bf68577a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,41 @@
# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
-pkgname=boxtron
-pkgver=0.5.0
+pkgname=boxtron-git
+_pkgname="${pkgname%-git}"
+pkgver=0.5.0.r2.e4bf54e
pkgrel=1
pkgdesc='Compatibility tool to run DOS games on Steam through native Linux DOSBox – NOTE: Won’t work as intended until next Steam beta cycle!'
arch=('i686' 'x86_64')
-url="https://github.com/dreamer/$pkgname"
+url="https://github.com/dreamer/$_pkgname"
license=('GPL')
depends=('dosbox' 'inotify-tools')
+makedepends=('git')
optdepends=(
'steam: The Steam client'
'timidity++: MIDI support'
'soundfont-fluid: MIDI support')
-install=$pkgname.install
-source=("$pkgname-$pkgver.tar.xz::$url/releases/download/v$pkgver/$pkgname.tar.xz")
-sha512sums=('054011dda43f5b923026bbb20913d46a752fb42818c27a9447787b03cab01184c16cfb0c4f23e5490c962a32c025b326abd90e2b9d6bc0ebfeed4bf83fda9eb1')
+install=$_pkgname.install
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+ sed -i -E '/^tool_(name|dir) +=/s/$/-git/' Makefile
+ sed -i -E '/^tool_name_display +=/s/$/ (git)/' Makefile
+ less Makefile
+ #exit 1
+}
+
+check() {
+ cd "$_pkgname"
+ make test
+}
package() {
- install -dm755 "$pkgdir"/usr/share/steam/compatibilitytools.d
- mv "$pkgname" "$pkgdir"/usr/share/steam/compatibilitytools.d/
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" prefix=/usr install
}