summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2019-10-04 16:23:58 +0200
committerFrederik “Freso” S. Olesen2019-10-04 16:23:58 +0200
commit58a44e4ab337b466924e1f0b13b4fc8ff27db717 (patch)
tree26f8b37b74e18b767e544b07a31b69b1bee3ab7a /PKGBUILD
parent2d3d81e4a120b2ce065e148165f79daaae7a5931 (diff)
downloadaur-58a44e4ab337b466924e1f0b13b4fc8ff27db717.tar.gz
boxtron: Build from source instead of (re)packaging pre-built package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eb0c5f5f4ab..0a996e9dea7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
pkgname=boxtron
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Compatibility tool to run DOS games on Steam through native Linux DOSBox – NOTE: Won’t work as intended until next Steam beta cycle!'
arch=('i686' 'x86_64')
url="https://github.com/dreamer/$pkgname"
license=('GPL')
depends=('dosbox' 'inotify-tools')
+makedepends=('git')
optdepends=(
'steam: The Steam client'
'timidity++: MIDI support'
'soundfont-fluid: MIDI support')
install=$pkgname.install
-source=("$pkgname-$pkgver.tar.xz::$url/releases/download/v$pkgver/$pkgname.tar.xz")
-sha512sums=('054011dda43f5b923026bbb20913d46a752fb42818c27a9447787b03cab01184c16cfb0c4f23e5490c962a32c025b326abd90e2b9d6bc0ebfeed4bf83fda9eb1')
+source=("git+$url.git#tag=v$pkgver")
+sha512sums=('SKIP')
+
+check() {
+ cd "$pkgname"
+ make test
+}
package() {
- install -dm755 "$pkgdir"/usr/share/steam/compatibilitytools.d
- mv "$pkgname" "$pkgdir"/usr/share/steam/compatibilitytools.d/
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" prefix=/usr install
}