summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2015-07-13 14:14:27 +0200
committermrxx2015-07-13 14:14:27 +0200
commit84a09cc426d74d91f52ef59b2e6fd68a23b3f744 (patch)
tree04763f4702b592e252c950055956731fb9de1d49 /PKGBUILD
parent159d741318f677f4e0d817081344e298507da531 (diff)
downloadaur-84a09cc426d74d91f52ef59b2e6fd68a23b3f744.tar.gz
Moved CGI directory to /usr/lib/cgi-bin, added samples
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e89ad1549d3d..6f00987ff71f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bozohttpd
pkgver=20150320
-pkgrel=1
+pkgrel=2
pkgdesc="A small and secure HTTP version 1.1 server"
arch=('i686' 'x86_64')
url="http://www.eterna.com.au/bozohttpd/"
@@ -13,8 +13,8 @@ optdepends=('php-cgi')
source=("http://www.eterna.com.au/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
'bozohttpd.service'
'bozohttpd.install'
- 'sample_index.html'
- 'sample_index.php'
+ 'sample.cgi'
+ 'sample_perl.cgi'
)
md5sums=('60e2cf933d028a096523214fab8e6590'
'SKIP'
@@ -35,15 +35,11 @@ build()
package()
{
cd "${pkgname}-${pkgver}"
- mkdir -p "${pkgdir}"/usr/{bin,share/{${pkgname},man/man8}}
+ mkdir -p "${pkgdir}"/usr/{bin,lib/cgi-bin,share/{${pkgname},man/man8}}
install -D *.* testsuite/*.* testsuite/data/*.* "${pkgdir}/usr/share/${pkgname}/"
install -m755 bozohttpd "${pkgdir}/usr/bin/"
install -m644 bozohttpd.8 "${pkgdir}/usr/share/man/man8/"
cd "$srcdir"
install -Dm644 bozohttpd.service "${pkgdir}"/usr/lib/systemd/system/bozohttpd.service
- mkdir -p -m 755 "${pkgdir}"/srv/http/{www,cgi-bin}
- install -Dm644 sample_index.html "${pkgdir}/srv/http/www/"
- chown nobody.nobody "${pkgdir}/srv/http/www/sample_index.html"
- install -Dm644 sample_index.php "${pkgdir}/srv/http/www/"
- chown nobody.nobody "${pkgdir}/srv/http/www/sample_index.php"
+ install -D *.cgi "${pkgdir}/usr/lib/cgi-bin/"
}