summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2018-02-02 04:57:27 +0800
committerJingbei Li2018-02-02 04:57:27 +0800
commit5bcd598a12ac934ae1667d8d975192b54e985367 (patch)
tree49f37786640ec5df6f49012383bbf3112b777ad4 /PKGBUILD
parentf1300633993c9bfe7dac381b2de1c241cc63df1f (diff)
downloadaur-5bcd598a12ac934ae1667d8d975192b54e985367.tar.gz
upgraded to 1.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD53
1 files changed, 26 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7aa9de32da2f..4c18d07f444d 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
# Maintainer: Jingbei Li <i@jingbei.li>
-
pkgname=brackets
-pkgver=1.11
+pkgver=1.12
pkgrel=1
-pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS. Stable git Tags."
+pkgdesc="An open source code editor for the web, written in JavaScript, HTML and CSS."
arch=('i686' 'x86_64')
url="http://brackets.io"
license=('MIT')
-depends=(alsa-lib nodejs npm desktop-file-utils gconf libgcrypt15 libudev0 nss)
+depends=(alsa-lib desktop-file-utils gconf libgcrypt15 libudev0-shim libxss libxtst nodejs npm nss pango)
optdepends=(
"google-chrome: to enable Live Preview"
"gnuplot: to enable node benchmarking"
@@ -16,50 +15,45 @@ optdepends=(
"hicolor-icon-theme: for hicolor theme hierarchy"
)
conflicts=("brackets-git" "brackets-bin")
-makedepends=('git' 'unzip' 'gtk2' 'python2' 'npm' 'gcc5')
+makedepends=('gcc5' 'git' 'gtk2' 'python2' 'unzip')
install=${pkgname}.install
-source=("git+https://github.com/adobe/brackets-shell.git#branch=linux-1547"
- #"git+https://github.com/adobe/brackets-shell.git#tag=release-${pkgver}"
- "git+https://github.com/adobe/brackets.git#tag=release-${pkgver}"
+source=("git+https://github.com/adobe/brackets#tag=release-${pkgver}"
+ "git+https://github.com/adobe/brackets-shell#tag=release-${pkgver}"
+ #"git+https://github.com/adobe/brackets-shell#branch=linux-1547"
)
md5sums=('SKIP' 'SKIP')
-
prepare() {
cd ${srcdir}/${pkgname}
git submodule update --init --recursive
}
build() {
+ #`npm install package` fails with https://registry.npmjs.org/
+ npm_registry=$(npm config get registry)
+ cd ${srcdir}/brackets
+ npm config set registry "https://registry.npm.taobao.org"
+ npm install package
+ npm config set registry "$npm_registry"
+
cd ${srcdir}/brackets
npm install
+ sed "/'npm-install',$/d" -i Gruntfile.js
node_modules/grunt-cli/bin/grunt build
cd ${srcdir}/brackets-shell
sed -i 's/python/python2/' gyp/gyp
npm install
- ##### environment cleaning due to branch switch ####
+ #environment cleaning due to branch switch
rm -rf out
- node_modules/grunt-cli/bin/grunt setup
+ node_modules/grunt-cli/bin/grunt cef icu node create-project
+ #use g++-5 to solve icu ABI issue
LINK=g++-5 make
}
package() {
cd ${srcdir}/brackets-shell
-
- install -dm755 "${pkgdir}/opt/brackets"
- cp -R out/Release/lib "${pkgdir}/opt/brackets/lib"
- cp -R out/Release/locales "${pkgdir}/opt/brackets/locales"
- cp -R out/Release/node-core "${pkgdir}/opt/brackets/node-core"
- install -Dm644 out/Release/cef.pak "${pkgdir}/opt/brackets/cef.pak"
- install -Dm644 out/Release/devtools_resources.pak "${pkgdir}/opt/brackets/devtools_resources.pak"
- install -Dm755 out/Release/Brackets "${pkgdir}/opt/brackets/Brackets"
- install -Dm755 out/Release/Brackets-node "${pkgdir}/opt/brackets/Brackets-node"
install -Dm755 installer/linux/debian/brackets "${pkgdir}/opt/brackets/brackets"
- for size in 32 48 128 256; do
- install -Dm644 "out/Release/appshell${size}.png" "${pkgdir}/opt/brackets/appshell${size}.png"
- done
-
install -dm755 "${pkgdir}/usr/bin"
ln -s /opt/brackets/brackets "$pkgdir/usr/bin/brackets"
@@ -67,12 +61,17 @@ package() {
install -Dm644 installer/linux/debian/brackets.desktop "${pkgdir}/usr/share/applications/brackets.desktop"
install -Dm644 installer/linux/debian/package-root/usr/share/icons/hicolor/scalable/apps/brackets.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/brackets.svg"
for size in 32 48 128 256; do
- install -Dm644 "out/Release/appshell${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/brackets.png"
+ install -Dm644 "out/Release/files/appshell${size}.png" "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/brackets.png"
done
+ cd out/Release
+ install -dm755 "${pkgdir}/opt/brackets"
+ cp -R {files,locales,node-core} "${pkgdir}/opt/brackets/"
+ find . -maxdepth 1 -type f -exec \
+ cp {} ${pkgdir}/opt/brackets/{} \;
+ chmod 4755 ${pkgdir}/opt/brackets/chrome-sandbox
+
cd ${srcdir}/${pkgname}
- # Copy samples
cp -R "samples" "${pkgdir}/opt/brackets/samples"
- # Copy www
cp -R "dist" "${pkgdir}/opt/brackets/www"
}