summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuglloc2015-10-06 22:05:07 +0200
committerBuglloc2015-10-06 22:05:07 +0200
commit1c6aafeb7336d3d29b6184d453e466712711bfb5 (patch)
treeab679acfc10d7733060b7b0fce9d9ffec2e8bada /PKGBUILD
parent98933f610af482fa842aa8e0c9b12773b0191957 (diff)
downloadaur-1c6aafeb7336d3d29b6184d453e466712711bfb5.tar.gz
Version 0.2.4.31
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f9ef1a74857..b4b747b16296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Andrew Krasichkov <buglloc _ at _ yandex _ dot _ru>
pkgname=brick
-pkgver=0.2.3.31
+pkgver=0.2.4.31
pkgrel=1
-pkgdesc="Unofficial Bitrix24 messenger client"
+pkgdesc="Bitrix24 messenger"
arch=('i686' 'x86_64')
url="https://github.com/buglloc/brick"
license=("MIT")
@@ -13,20 +13,20 @@ conflicts=("brick-git" "mesa-demos")
makedepends=("p7zip" "cmake")
install=${pkgname}.install
source=("https://github.com/buglloc/brick/archive/v${pkgver}.tar.gz")
-source_i686=("https://github.com/buglloc/cef-builds/raw/79c6f03ac3d4eb3332d6c374d9a9cb0fa3be742b/libs/cef-i686.tar.gz")
-sha256sums=("00f4a467ba10dcc586bdebbf2c912a202950a9e34b0a337cf635b96bac48df00")
-sha256sums_i686=("134454435e24ecae8be9430cb36e2a6095f780443e2e09ac05a4e41beb85d253")
+sha256sums=("8e14f23b07b2585bf95a072dc5b5d26a0ce92754badf263a7d088f75627c00f8")
+source_x86_64=("https://github.com/buglloc/cef-builds/raw/68a8676091f1caa9acaf1f66531a272b99846367/libs/cef-x86_64.tar.gz")
+sha256sums_x86_64=("707dbbcf036770cffb163d14d747e4edc4e769e8f813d3cd29c847426e2268ca")
+source_i686=("https://github.com/buglloc/cef-builds/raw/2c8ddaf890b7b9cc9353f7bad745109c4fd2083e/libs/cef-i686.tar.gz")
+sha256sums_i686=("fa20cb5e2dd47097861e90e7b0308bf3c4d01cc8d058ef2109b1109609181876")
+noextract=("cef-i686.tar.gz" "cef-x86_64.tar.gz")
+prepare() {
+ mkdir -p "brick-${pkgver}/Release/"
+ tar -xzf "cef-${CARCH}.tar.gz" --directory "brick-${pkgver}/Release"
+}
build() {
cd ${srcdir}
-
- if [ $CARCH == "i686" ];
- then
- rm -f "brick-${pkgver}/Release/*"
- cp -arf cef-i686/* "brick-${pkgver}/Release"
- fi
-
mkdir -p out
cd out
cmake -DCMAKE_INSTALL_PREFIX=${pkgdir} -DUNITY_DESKTOP=OFF "../brick-${pkgver}"