summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuglloc2015-06-17 11:34:34 +0200
committerBuglloc2015-06-17 11:34:34 +0200
commiteafb36074d31bccf7c01924967a6e58c0b679ded (patch)
treef917118eca75336af5cb499cf8dc7ca737bf2394 /PKGBUILD
downloadaur-eafb36074d31bccf7c01924967a6e58c0b679ded.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c958b6bb0e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andrew Krasichkov <buglloc _ at _ yandex _ dot _ru>
+
+pkgname=brick
+pkgver=0.1.26.31
+pkgrel=1
+pkgdesc="Unofficial Bitrix24 messenger client"
+arch=('i686' 'x86_64')
+url="https://github.com/buglloc/brick"
+license=("MIT")
+depends=("alsa-lib" "desktop-file-utils" "gconf" "libxtst" "libxss" "xdg-utils" "gtk2" "libnotify" "nss")
+optdepends=()
+conflicts=("brick-unity" "brick-git" "brick-unity-git")
+makedepends=("p7zip" "cmake")
+install=${pkgname}.install
+source=("https://github.com/buglloc/brick/archive/v${pkgver}.tar.gz")
+source_i686=("https://github.com/buglloc/cef-builds/raw/79c6f03ac3d4eb3332d6c374d9a9cb0fa3be742b/libs/cef-i686.tar.gz")
+sha256sums=("f96affeb0d2270057f81e0123376c1830539d8a3c69efb3cc4dde0b5bf6459b2")
+sha256sums_i686=("134454435e24ecae8be9430cb36e2a6095f780443e2e09ac05a4e41beb85d253")
+
+
+build() {
+ cd ${srcdir}
+
+ if [ $CARCH == "i686" ];
+ then
+ rm -f "brick-${pkgver}/Release/*"
+ cp -arf cef-i686/* "brick-${pkgver}/Release"
+ fi
+
+ mkdir -p out
+ cd out
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir} -DUNITY_DESKTOP=OFF "../brick-${pkgver}"
+ make
+}
+
+package() {
+ cd ${srcdir}/out
+ make install
+ install -dm755 "${pkgdir}/usr/bin"
+ rm -f "${pkgdir}/usr/bin/brick"
+ ln -s /opt/brick/brick "${pkgdir}/usr/bin/brick"
+}