summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron McDaniel (mcd1992)2018-05-14 15:20:56 -0500
committerAaron McDaniel (mcd1992)2018-05-14 15:20:56 -0500
commit0a92c318e784d9fbf34c33e075c97cf0d889c4b1 (patch)
treecb599bae51d2c01457dca801ae319f06f5137a4f /PKGBUILD
parentd5e55769464db169882ad3709ad7d375ef24de96 (diff)
downloadaur-0a92c318e784d9fbf34c33e075c97cf0d889c4b1.tar.gz
Fixed new issue with cmake targeting incorrect openssl lib
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eead2c3f35de..8bd0b6aca501 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
pkgname=bro-git
-pkgver=2.5.r365.g7c03f4dec
+pkgver=2.5.r569.g057c982b9
pkgrel=1
pkgdesc='A powerful framework for network analysis and security monitoring. (IDS Intrusion Detection System)'
url='https://www.bro.org'
@@ -11,8 +11,8 @@ makedepends=('git' 'fakeroot' 'cmake' 'make' 'flex' 'bison' 'swig')
depends=('bash' 'libpcap' 'openssl-1.0' 'zlib' 'python')
optdepends=('geoip' 'gperftools' 'sendmail' 'curl' 'actor-framework')
backup=('etc/bro/broctl.cfg' 'etc/bro/networks.cfg' 'etc/bro/node.cfg' 'etc/bro/broccoli.conf')
-source=("${pkgname}::git+https://github.com/bro/bro.git")
-md5sums=('SKIP')
+source=("${pkgname}::git+https://github.com/bro/bro.git" 'cmake_OpenSSLTests.patch')
+md5sums=('SKIP' 'c0bd228adfa3d34cb7e6623467f62502')
pkgver() {
cd ${pkgname}
@@ -26,11 +26,13 @@ prepare() {
# Update submodules
git submodule update --init --recursive
+ # Change the cmake/OpenSSLTests.cmake file to bypass targeting the wrong library version...
+ patch -N -p1 -i "${srcdir}/cmake_OpenSSLTests.patch" || true
+
# Create Makefiles
- ./configure --prefix=/usr --spooldir=/var/spool/bro --logdir=/var/log/bro --conf-files-dir=/etc/bro
+ ./configure --prefix=/usr --spooldir=/var/spool/bro --logdir=/var/log/bro --conf-files-dir=/etc/bro --with-openssl=/usr/include/openssl-1.0
# Temporary fix until openssl-1.1 is supported
- # (Does this fix break i686 builds?)
sed -i 's/^OPENSSL_CRYPTO_LIBRARY.*/OPENSSL_CRYPTO_LIBRARY:FILEPATH=\/usr\/lib\/openssl-1.0\/libcrypto.so/' build/CMakeCache.txt
sed -i 's/^OPENSSL_INCLUDE_DIR.*/OPENSSL_INCLUDE_DIR:PATH=\/usr\/include\/openssl-1.0/' build/CMakeCache.txt
sed -i 's/^OPENSSL_SSL_LIBRARY.*/OPENSSL_SSL_LIBRARY:FILEPATH=\/usr\/lib\/openssl-1.0\/libssl.so/' build/CMakeCache.txt