summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlucasheld2021-09-26 12:49:02 +0200
committerlucasheld2021-09-26 12:49:02 +0200
commit5d0a034f65467544a46ae7dcd7266bfaa1c7be76 (patch)
tree0d28a4ea19e9621d754ce9ffea59c38b45b4e2b3 /PKGBUILD
downloadaur-5d0a034f65467544a46ae7dcd7266bfaa1c7be76.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8424d656acfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=brother-dcp165c
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Driver for Brother DCP-165C printer"
+url="https://support.brother.com/g/b/producttop.aspx?c=de&lang=de&prod=dcp165c_all"
+license=('custom:brother')
+depends=('a2ps' 'cups' 'lib32-gcc-libs' 'lib32-glibc')
+optdepends=('brscan3: scanner support.')
+install="brother-dcp165c.install"
+arch=('i686' 'x86_64')
+
+md5sums=('51b9c8ea31dc37540cb8264bb05ca3f7'
+ '22a0932c6547a682af4a16fb86100614'
+ '0bf765de513b8d1e37567ecf2c04897e')
+
+source=(
+ "fix_lp.patch" \
+ "https://download.brother.com/welcome/dlf005378/dcp165clpr-1.1.2-2.i386.rpm" \
+ "https://download.brother.com/welcome/dlf005380/dcp165ccupswrapper-1.1.2-2.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /usr/local/Brother/Printer/dcp165c/cupswrapper/cupswrapperdcp165c
+}
+
+package() {
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcp165c "$pkgdir"/usr/bin/
+ cp -R $srcdir/usr/. $pkgdir/usr
+}