summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilhelm Schuster2018-09-04 22:12:05 +0200
committerWilhelm Schuster2018-09-04 22:18:37 +0200
commit32549a8b6e722db525436635bc3091ba641ceba6 (patch)
tree117e60fdf158d9714c3347d1d7f6857068bd8dcc /PKGBUILD
parent0c80b967606e86f23fd68f674d06adf168abc7d0 (diff)
downloadaur-32549a8b6e722db525436635bc3091ba641ceba6.tar.gz
Revamp package
- Retab - Quote path variables in some places - Update upstream sources - Update cupswrapper to 1.1.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD104
1 files changed, 53 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1056378187ff..65afcc465316 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,68 @@
-# Maintainer: sven-to <aur@sven.to>
+# Maintainer: <aur@rot13.io>
+# Contributor: sven-to <aur@sven.to>
# Based on AUR Package brother-dcp7055 by ewolnux <thinux@gmx.fr>
-_brother_modell="dcp9017cdw"
-pkgname="brother-$_brother_modell"
+_brother_model="dcp9017cdw"
+_cupswrapper_ver="1.1.4"
+
+pkgname="brother-$_brother_model"
pkgver="1.1.3"
-pkgrel=0
+pkgrel=1
pkgdesc="LPR and CUPS driver for the Brother DCP-9017CDW"
arch=('i686' 'x86_64')
url="http://solutions.brother.com/linux/en_us/"
license=('custom:brother commercial license')
depends=('cups')
+depends_x86_64=('lib32-glibc')
+optdepends=('brscan4: sane scanning support')
install="$pkgname.install"
-# Package Info: wget http://www.brother.com/pub/bsc/linux/infs/DCP9017CDW
+# Package Info: wget http://www.brother.com/pub/bsc/linux/infs/DCP9017CDW
source=(
- "http://www.brother.com/pub/bsc/linux/packages/${_brother_modell}cupswrapper-$pkgver-$pkgrel.i386.rpm"
- "http://www.brother.com/pub/bsc/linux/packages/${_brother_modell}lpr-$pkgver-$pkgrel.i386.rpm"
- 'cupswrapper-license.txt'
- 'lpr-license.txt'
-)
-md5sums=(
- 'bc7a8a0f6573679c7328ff4885f37eb1'
- 'e0af5c747096abcaed076ca063035cc8'
- '97ad0cffd216059e9d1d3121899d8646'
- '5e87a3dc0f3e3438c088eda0f3565f0d'
+ "http://download.brother.com/welcome/dlf102666/${_brother_model}cupswrapper-$_cupswrapper_ver-0.i386.rpm"
+ "http://download.brother.com/welcome/dlf102665/${_brother_model}lpr-$pkgver-0.i386.rpm"
+ 'cupswrapper-license.txt'
+ 'lpr-license.txt'
)
-if test "$CARCH" == x86_64; then
- depends+=('lib32-glibc')
-fi
+md5sums=('3a99a20267fd8db51b861097fe0d40e2'
+ 'e0af5c747096abcaed076ca063035cc8'
+ '97ad0cffd216059e9d1d3121899d8646'
+ '5e87a3dc0f3e3438c088eda0f3565f0d')
+
prepare() {
-# do not install in '/usr/local'
- if [ -d $srcdir/usr/local/Brother ]; then
- install -d $srcdir/usr/share
- mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
- rm -rf $srcdir/usr/local
- sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
- fi
-# setup cups-directories
- install -d $srcdir/usr/share/cups/model
- install -d $srcdir/usr/lib/cups/filter
-# go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
- cd `find . -type d -name 'cupswrapper'`
- if [ -f cupswrapper* ]; then
- _wrapper_source=`ls cupswrapper*`
- sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
- sed -i '/^sleep/d' $_wrapper_source
- sed -i '/^lpadmin/d' $_wrapper_source
- sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
- sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
- sed -i 's|/model/Brother|/model|g' $_wrapper_source
- sed -i 's|lpinfo|echo|g' $_wrapper_source
- export srcdir=$srcdir
- ./$_wrapper_source
- sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
- sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
- rm $_wrapper_source
- fi
-# /etc/printcap is managed by cups
- rm `find $srcdir -type f -name 'setupPrintcap*'`
+ # do not install in '/usr/local'
+ if [ -d "$srcdir/usr/local/Brother"]; then
+ install -d "$srcdir"/usr/share
+ mv "$srcdir"/usr/local/Brother/ "$srcdir"/usr/share/brother
+ rm -rf "$srcdir"/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+ # setup cups-directories
+ install -d "$srcdir"/usr/share/cups/model
+ install -d "$srcdir"/usr/lib/cups/filter
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source="$(ls cupswrapper*)"
+ sed -i '/^\/etc\/init.d\/cups/d' "$_wrapper_source"
+ sed -i '/^sleep/d' "$_wrapper_source"
+ sed -i '/^lpadmin/d' "$_wrapper_source"
+ sed -i 's|/usr|$srcdir/usr|g' "$_wrapper_source"
+ sed -i 's|/opt|$srcdir/opt|g' "$_wrapper_source"
+ sed -i 's|/model/Brother|/model|g' "$_wrapper_source"
+ sed -i 's|lpinfo|echo|g' "$_wrapper_source"
+ export srcdir="$srcdir"
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' "$srcdir"/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" "$srcdir"/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+ # /etc/printcap is managed by cups
+ rm `find "$srcdir" -type f -name 'setupPrintcap*'`
}
+
package() {
- cp -R $srcdir/usr $pkgdir
- if [ -d $srcdir/opt ]; then cp -R $srcdir/opt $pkgdir; fi
- install -m 644 -D cupswrapper-license.txt $pkgdir/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
- install -m 644 -D lpr-license.txt $pkgdir/usr/share/licenses/${pkgname}/lpr-licence.txt
+ cp -R "$srcdir"/usr "$pkgdir"
+ if [ -d "$srcdir"/opt ]; then cp -R "$srcdir"/opt "$pkgdir"; fi
+ install -m 644 -D cupswrapper-license.txt "$pkgdir"/usr/share/licenses/${pkgname}/cupswrapper-licence.txt
+ install -m 644 -D lpr-license.txt "$pkgdir"/usr/share/licenses/${pkgname}/lpr-licence.txt
}