aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrognon2016-10-22 07:55:14 +0200
committergrognon2016-10-22 07:55:14 +0200
commitd60c109d3d21fb10f77ed3662941a4e621ee8b0d (patch)
treeed2bb6069dde10d276cb3026f66e44e25365e853 /PKGBUILD
downloadaur-d60c109d3d21fb10f77ed3662941a4e621ee8b0d.tar.gz
First commit to Aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88f1996cebde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Alessio Bianchi <venator85@gmail.com>
+# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
+# Contributor: Javier Cordero <jneight@gmail.com>
+# Contributor: Vieux Grognon <vieux@grognon.net>
+# Maintainer: Vieux Grognon <vieux@grognon.net>
+
+pkgname=brother-dcpj140w
+pkgver=1.1.3
+pkgrel=3
+pkgdesc="Driver for the Brother DCP-J315W wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install="brother-dcpj140w.install"
+arch=('i686' 'x86_64')
+
+md5sums=('69229583e5d43d82e5655f74729c05ba'
+ '599a7667f2c805d5dbc2fa655832f17c'
+ 'fa2d50677492bfc83e27184f316061c3')
+
+source=(
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wcupswrapper-$pkgver-6.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+post_install() {
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
+}
+
+package()
+{
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
+}