summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Dietrich2016-03-22 20:54:55 +0100
committerDaniel Dietrich2016-03-22 20:54:55 +0100
commite31be74a14d281f2866a9f7c50b7c83454e6355a (patch)
treea6aec747dc28e120fe72d453c8194942a4c833a1 /PKGBUILD
downloadaur-e31be74a14d281f2866a9f7c50b7c83454e6355a.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4432a82a6daa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Dietrich <shaddow2k@@gmail..com>
+# Based on the DCP-J552DW PKGBUILD -> Marius Rejdak <mariuswol at gmail dot com>
+pkgname=brother-dcpj562dw
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Driver for the Brother DCP-J562DW wifi multifuncional printer"
+url="http://solutions.brother.com/linux/en_us/index.html"
+license=('custom:brother')
+depends=('a2ps' 'cups')
+makedepends=('rpmextract')
+install='brother-dcpj562dw.install'
+arch=('i686' 'x86_64')
+
+md5sums=('a1249f09228e540a1404497dbd622720'
+ '28aaf6a403c9cd2d9496243a978e7a0c'
+ '006d9ba0e9906f4cf906b1c58ebe8a46')
+
+source=(
+ "fix_lp.patch" \
+ "http://download.brother.com/welcome/dlf102101/dcpj562dwlpr-$pkgver-0.i386.rpm" \
+ "http://download.brother.com/welcome/dlf102102/dcpj562dwcupswrapper-$pkgver-0.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package()
+{
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj562dw "$pkgdir"/usr/bin/
+ cp -R "$srcdir"/opt "$pkgdir"/opt
+}