summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchiso2019-06-22 14:36:46 +0900
committerArchiso2019-06-22 14:36:46 +0900
commit18c4ab77232ac9c2c8fb886fb7a7a17a989d74ee (patch)
treebd85b75311867b127afcc28ad1151fcff7d0809e /PKGBUILD
downloadaur-brother-dcpj577n.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31d3357b3ce0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nie(sha) <nieein56@tamag.org>
+
+pkgname="brother-dcpj577n"
+pkgver="1.0.5"
+pkgrel="0"
+pkgdesc="Brother DCP-J577N CUPS driver"
+url="http://brother.co.jp/"
+license=('EULA')
+install="brother-dcpj577n.install"
+depends=('cups' 'a2ps')
+arch=('i686' 'x86_64')
+
+md5sums=(
+ '0123659bafc46e84ca66316dc511f0f8'
+ '23c3134e53d7a38778ba8b0fe2e93d64'
+)
+
+source=(
+ 'fix_lp.patch' \
+ "https://download.brother.com/welcome/dlf104037/dcpj577npdrv-$pkgver-$pkgrel.i386.rpm"
+)
+
+build() {
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
+}
+
+package() {
+ install -d "$pkgdir"/usr/bin
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj577n "$pkgdir"/usr/bin/
+ cp -R "$srcdir"/opt "$pkgdir"/opt
+}
+