summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorb3niup2020-03-02 14:53:18 +0100
committerb3niup2020-03-02 14:53:18 +0100
commita9d5183ee41d438482b01b75e3aff05be5425a6b (patch)
tree81c5fe8b17ca284187866f6509f3d671ed63252d /PKGBUILD
parent80a3562c82de958abb5860e2c4acfa5378785a0e (diff)
downloadaur-a9d5183ee41d438482b01b75e3aff05be5425a6b.tar.gz
Fix custom options parsing and landscape A5 printing.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26fa8a59a7c6..5f944d6f9aa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
# based on brother-hll2300d by Mykola Bespaliuk (kolkabes [at] gmail [dot] com)
pkgname=brother-hll2310d
pkgver=4.0.0
-pkgrel=1
+_pkgrel=1
+pkgrel=2
pkgdesc="Brother HL-L2310D CUPS driver"
url="http://www.brother.com"
arch=('x86_64' 'i686')
depends=('perl' 'bash' 'ghostscript')
license=('custom:Brother')
source=(
- https://download.brother.com/welcome/dlf103531/hll2310dpdrv-${pkgver}-${pkgrel}.i386.rpm
+ "https://download.brother.com/welcome/dlf103531/hll2310dpdrv-${pkgver}-${_pkgrel}.i386.rpm"
+ "wrapper.patch"
)
md5sums=(
'786ededd9b19d559dcb49160bb81c8a2'
+ '7e4c0e3834def252fc58f0dcdad7cbb2'
)
if [[ "$CARCH" == "x86_64" ]]; then
@@ -23,6 +26,10 @@ package() {
mkdir -p "${pkgdir}/opt"
cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+ cd ${pkgdir}
+ patch -Np0 -i "${srcdir}/wrapper.patch"
+ cd -
+
cd ${pkgdir}/opt/brother/Printers/HLL2310D/lpd
for i in brprintconflsr3 rawtobr3; do ln -s ${CARCH}/$i .; done
cd -