summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2017-08-21 12:13:48 -0700
committerLlewelyn Trahaearn2017-08-21 12:13:48 -0700
commit9924a39d265bcc8b0752d81ba2fadf6027ab610d (patch)
treea673d363f196924e825f8316ceb97c3852573b11 /PKGBUILD
parentfdc51c8bb4807d9210645a5f6a48be242e8c06b2 (diff)
downloadaur-9924a39d265bcc8b0752d81ba2fadf6027ab610d.tar.gz
Clean up patch and update depends from foomatic-filters to cups-filters as cups-filters no longer provides foomatic-filters.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3ff4416f5d4..9462c10c3c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,38 @@
-# Maintainer: Oleksandr Natalenko <pfactum@gmail.com>
-# Author of original PKGBUILD: Igor Mosyagin <c6h10o5@gmail.com>
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict [at] GMail [dot] com>
+# Contributor: Oleksandr Natalenko <pfactum [at] gmail [dot] com>
+# Contributor: Igor Mosyagin <c6h10o5 [at] gmail [dot] com>
+
pkgname=brother-mfc-7860dw
pkgver=2.1.0
-_driver_ver=2.1.0
_wrapper_ver=2.0.4
-pkgrel=3
+pkgrel=4
pkgdesc="CUPS driver for Brother MFC-7860DW printer"
arch=('i686' 'x86_64')
-url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+url="http://support.brother.com/g/b/producttop.aspx?c=us_ot&lang=en&prod=mfc7860dw_all"
license=('GPL')
depends=()
if [ "$CARCH" = "x86_64" ]; then
- depends=('cups' 'ghostscript' 'gsfonts' 'foomatic-filters' 'lib32-glibc')
+ depends=('cups' 'ghostscript' 'gsfonts' 'cups-filters' 'lib32-glibc')
else
- depends=('cups' 'ghostscript' 'gsfonts' 'foomatic-filters')
+ depends=('cups' 'ghostscript' 'gsfonts' 'cups-filters')
fi
-install=brother-mfc-7860dw.install
-source=(http://www.brother.com/pub/bsc/linux/dlf/mfc7860dwlpr-${_driver_ver}-1.i386.rpm
+source=(http://www.brother.com/pub/bsc/linux/dlf/mfc7860dwlpr-${pkgver}-1.i386.rpm
http://www.brother.com/pub/bsc/linux/dlf/cupswrapperMFC7860DW-${_wrapper_ver}-2.i386.rpm
brother-mfc-7860dw.patch)
sha256sums=('7886fbbaa9aa980d6f6b08f4a584f8614857e6ab1511c2b494d3b8e1dedafd14'
'2ab019790bd88b65b592b1a700f9e96018130bcbfc19cde5017f0230e7f77e98'
- 'a20a9c1f537b18593eab3a8274a9a78cf5c00d29faf63c22737dc302d9b7e441')
+ '1123ca4599d8404fee800d5f439ad862ff4ad49d252fca527c170d9500d8a7f3')
prepare() {
- cd "${srcdir}"
-
- # patch files to adhere arch packaging standard
+ # Modify file locations to align with packaging standards for Arch Linux systems and tame the wrapper.
patch -p1 < "${srcdir}/brother-mfc-7860dw.patch" || return 1
}
build() {
- cd "${srcdir}"
-
- # generate ppd and wrapper file
sh "${srcdir}/usr/local/Brother/Printer/MFC7860DW/cupswrapper/cupswrapperMFC7860DW-${_wrapper_ver}"
}
package() {
- # put files where they belong
mkdir -p "${pkgdir}/usr/share/brother"
cp -r "${srcdir}/usr/local/Brother/Printer" "${pkgdir}/usr/share/brother/printer"
cp -r "${srcdir}/var" "${pkgdir}/"
@@ -49,4 +43,3 @@ package() {
install -m 644 -D ppd_file "${pkgdir}/usr/share/cups/model/MFC7860DW.ppd"
install -m 755 -D wrapper "${pkgdir}/usr/lib/cups/filter/brlpdwrapperMFC7860DW"
}
-