summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorForgottenUmbrella2019-05-26 18:41:45 +1000
committerForgottenUmbrella2019-05-26 18:41:45 +1000
commitde9f444211d4a8508f35eb621db22b749c266dea (patch)
tree45788c5ce00daffd700f649d0a13c5b79d27741f /PKGBUILD
parent13fdc91b65d47e23af0b1fbedb86cd650c238cba (diff)
downloadaur-brother-mfc-9335cdw.tar.gz
Fix incorrect deb source and rpmextract command
Use RPM package instead of DEB package, in accordance with the Arch Wiki: https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Custom_drivers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99cba0095428..0412014fac0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=brother-mfc-9335cdw
pkgver=1.1.4
-pkgrel=4
+pkgrel=5
pkgdesc='LPR and CUPS drivers for the Brother MFC-9335CDW'
arch=('i686' 'x86_64')
url='http://support.brother.com/g/s/id/linux/en/index.html'
@@ -14,14 +14,14 @@ optdepends=('brscan4: scanning support'
makedepends=('rpmextract')
install='brother-mfc-9335cdw.install'
changelog='changelog.md'
-source=('http://download.brother.com/welcome/dlf102677/mfc9335cdwlpr-1.1.3-0.i386.deb'
- 'http://download.brother.com/welcome/dlf102678/mfc9335cdwcupswrapper-1.1.4-0.i386.deb')
-md5sums=('f993eb5322df2c9519a86ac0afcbb197'
- 'f3afb684911c55a131532bb8cfdbc672')
+source=('https://download.brother.com/welcome/dlf102675/mfc9335cdwlpr-1.1.3-0.i386.rpm'
+ 'https://download.brother.com/welcome/dlf102676/mfc9335cdwcupswrapper-1.1.4-0.i386.rpm')
+md5sums=('8f37eaeb181e9f2993b719294e944dc5'
+ '41108dca49edd1f014c54d9333048d4e')
package() {
- rpmextract mfc9335cdwlpr-1.1.3-0.i386.rpm
- rpmextract mfc9335cdwcupswrapper-1.1.4-0.i386.rpm
+ rpmextract.sh mfc9335cdwlpr-1.1.3-0.i386.rpm
+ rpmextract.sh mfc9335cdwcupswrapper-1.1.4-0.i386.rpm
mv $srcdir/usr/ $pkgdir/
mv $srcdir/opt/ $pkgdir/
}