summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStick2017-09-12 21:50:48 -0500
committerStick2017-09-12 21:53:58 -0500
commit1ebe0abccf287155f9a3211d80263737c557d260 (patch)
tree9e496d7291cf4f22f88448e6d1b636f09c035ae0 /PKGBUILD
parenta82ff9c45cf6bbd2c713d25685ddc7b6cefd1610 (diff)
downloadaur-1ebe0abccf287155f9a3211d80263737c557d260.tar.gz
update maintainer, shellcheck
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 019995cb987d..980d142efdbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
-# Maintainer: Eric Lehmann <katyl@katyl.info>
+# Maintainer: Nathaniel Stickney <nstickney@gmail.com>
+# Contributor: Eric Lehmann <katyl@katyl.info>
# Contributor: Peter Vasil <mail@petervasil.net>
+# shellcheck disable=SC2034,SC2148,SC2154
+
pkgname="brother-mfc-j480dw"
pkgver="1.0.0"
pkgrel=0
pkgdesc="LPR and CUPS driver for the Brother MFC-j480DW"
url="http://solutions.brother.com/linux/en_us/"
-arch=("i686" "x86_64")
+arch=('i686' 'x86_64')
license=('custom:brother commercial license')
-depends=(cups ghostscript a2ps)
+depends=('cups' 'ghostscript' 'a2ps')
install="$pkgname.install"
source=(
"http://download.brother.com/welcome/dlf102091/mfcj480dwlpr-$pkgver-$pkgrel.i386.rpm"
@@ -27,6 +30,7 @@ prepare() {
if [ -d $srcdir/usr/local/Brother ]; then
install -d $srcdir/usr/share
mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ # shellcheck disable=SC2115
rm -rf $srcdir/usr/local
sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
fi