summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Westermann2015-06-11 10:41:29 +0200
committerLucas Westermann2015-06-11 10:41:29 +0200
commit0a8d077f52d32deef23004ff843e3026b0554607 (patch)
tree125eab1b270ef3644fb6ef20da766651a2cc0e96 /PKGBUILD
downloadaur-0a8d077f52d32deef23004ff843e3026b0554607.tar.gz
Initial import (move from AUR3)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a8df2fd605d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lswest lswest34 <at> gmail.com
+# Based on brother-mfc-j6710dw package from AUR
+
+_model="j6510dw"
+pkgname="brother-mfc-$_model"
+pkgver="3.0.0"
+pkgrel=3
+_revision=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J6510DW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+install="brother-mfc-${_model}.install"
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+
+build() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "mfc${_model}" ] || (mkdir mfc${_model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfc${_model};done || return 1
+ cd mfc${_model} || return 1
+ cd opt/brother/Printers/mfc${_model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${_model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${_model}/opt/brother/Printers/mfc${_model}/inf/setupPrintcapij || return 1
+}
+package() {
+ cp -rf $srcdir/mfc${_model}/usr/ $pkgdir/ || return 1
+ cp -rf $srcdir/mfc${_model}/opt/ $pkgdir/ || return 1
+}
+md5sums=('b45aa1c4524eceecaf8f620a3abe1c61'
+ '753494cf9dabdc35987bff23aa28836b')