summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBonnee2018-07-04 23:49:30 +0200
committerBonnee2018-07-04 23:49:30 +0200
commit87fd77192ea925fcd960afad8a1c8066601a2cd1 (patch)
tree43e8bd621ca26e0d4557bdb2e214c76bc9a75608 /PKGBUILD
parent35a3522be06c481b10af1372f1b804e3ef3cd098 (diff)
downloadaur-87fd77192ea925fcd960afad8a1c8066601a2cd1.tar.gz
Update install method
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80bc29830fab..9f2234a673cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
# Maintainer: Matteo Bonora <bonora.matteo@gmail.com>
-model="l8900cdw"
-pkgname="brother-mfc-${model}"
+_model="l8900cdw"
+pkgname="brother-mfc-${_model}"
pkgver="1.2.0"
-_cupsver="1.3.0"
-pkgrel=0
-_revision=0
+pkgrel=1
pkgdesc="LPR and CUPS driver for the Brother MFC-L8900CDW"
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
arch=('i686' 'x86_64')
-license=('EULA')
-install="brother-mfc-${model}.install"
-depends=('tcsh' 'perl' 'a2ps' 'lib32-libcups')
-source=("mfc${model}lpr-${pkgver}-${_revision}.i386.rpm::http://download.brother.com/welcome/dlf103216/mfc${model}lpr-${pkgver}-${_revision}.i386.rpm"
- "mfc${model}cupswrapper-${_cupsver}-${_revision}.i386.rpm::http://download.brother.com/welcome/dlf103225/mfc${model}cupswrapper-${_cupsver}-${_revision}.i386.rpm")
+license=('GPL2' 'custom:Brother EULA')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+source=(http://download.brother.com/welcome/dlf103216/mfc${_model}lpr-${pkgver}-0.i386.rpm
+ http://download.brother.com/welcome/dlf103225/mfc${_model}cupswrapper-1.3.0-0.i386.rpm)
sha256sums=('82cb8b3710523b546e40e1280275ecc1689b50294644d6b81a25cbffc385e8c4'
'd92bbb84b6b66aad097b705dd6b2a53d19cab79fde546ad7a25e4952ee4547fa')
-
package() {
- cp -rf $srcdir/usr/ $pkgdir/ || return 1
- cp -rf $srcdir/opt/ $pkgdir/ || return 1
+ install -d ${pkgdir}/usr/share/cups/model/Brother
+ install -d ${pkgdir}/usr/share/ppd/Brother
+ install -d ${pkgdir}/usr/lib/cups/filter
+
+ install -Dm755 ${srcdir}/usr/bin/brprintconf_mfc${_model} ${pkgdir}/usr/bin/brprintconf_mfc${_model}
+ install -Dm644 ${srcdir}/opt/brother/Printers/mfc${_model}/cupswrapper/brother_mfc${_model}_printer_en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ install -Dm644 ${srcdir}/opt/brother/Printers/mfc${_model}/cupswrapper/brother_mfc${_model}_printer_en.ppd ${pkgdir}/usr/share/ppd/Brother
+
+ ln -s /opt/brother/Printers/mfc${_model}/cupswrapper/brother_lpdwrapper_mfc${_model} ${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_mfc${_model}
+
+ cp -r ${srcdir}/opt ${pkgdir}/opt
}