summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2019-05-30 16:15:55 +0200
committerKarol Babioch2019-05-30 16:19:58 +0200
commit8ffc82624d2bf9578deb7775412e18f48da57ed8 (patch)
tree35e5fef6ca30f04f3943398abadb213da1b3281e /PKGBUILD
parent8d09b1bb2bed1f5a8963bf268d7d2c01fb6fdaf4 (diff)
downloadaur-8ffc82624d2bf9578deb7775412e18f48da57ed8.tar.gz
Bump version to 3.1.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD103
1 files changed, 46 insertions, 57 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0e6c9ebb47a..d1e19da16c74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,75 +1,64 @@
# Maintainer: Karol Babioch <karol@babioch.de>
-# Inspired by package brother-dcp130c
-pkgname='brother-ql720nw'
-pkgver=1.1.4r0
-pkgrel=3
+pkgname=brother-ql720nw
+pkgver=3.1.5r0
+pkgrel=1
pkgdesc='LPR and CUPS driver for Brother QL-720NW label printer'
-url='http://solutions.brother.com/linux/en_us/'
+url='https://support.brother.com'
arch=('i686' 'x86_64')
license=('custom')
depends=('cups')
-if [ "$CARCH" = 'x86_64' ]; then
- depends+=('lib32-glibc')
-fi
-conflicts=('brother-ql720nw-cupswrapper' 'brother-ql720nw-lpr')
-provides=('brother-ql720nw-cupswrapper' 'brother-ql720nw-lpr')
-install="$pkgname.install"
-source=("http://download.brother.com/welcome/dlfp002203/ql720nwlpr-${pkgver/r/-}.i386.rpm"
- "http://download.brother.com/welcome/dlfp002205/ql720nwcupswrapper-${pkgver/r/-}.i386.rpm"
- 'LICENSE')
-sha256sums=('edc09ff6b91676dbe1d4ae4e0d7ee880867102b87fd0d4e5b10dd9b421dc1f5b'
- 'feaf221669cfbc48862c6e532e14656f9f96daef255316fdb754830ec853657a'
- 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+install="${pkgname}.install"
+source=("https://download.brother.com/welcome/dlfp002203/ql720nwpdrv-${pkgver/r/-}.i386.rpm")
+sha256sums=('07c2923aa60c502dae449d8716e4012331060fc60329098d1b92bb45064a8136')
prepare()
{
- # do not install in '/usr/local'
- if [ -d $srcdir/usr/local/Brother ]; then
- install -d $srcdir/usr/share
- mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
- rm -rf $srcdir/usr/local
- sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
- fi
+ # Create necessary CUPS directories
+ install -d "${srcdir}/usr/share/cups/model"
+ install -d "${srcdir}/usr/lib/cups/filter"
- # setup cups directories
- install -d "$srcdir/usr/share/cups/model"
- install -d "$srcdir/usr/lib/cups/filter"
+ # Locate cupswrapper script
+ cd $(find -type d -name 'cupswrapper')
+ _cupswrapper=$(ls cupswrapper*)
- # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
- cd `find . -type d -name 'cupswrapper'`
- if [ -f cupswrapper* ]; then
- _wrapper_source=`ls cupswrapper*`
- sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
- sed -i '/^sleep/d' $_wrapper_source
- sed -i '/^echo lpadmin/d' $_wrapper_source
- sed -i '/^lpadmin/d' $_wrapper_source
- sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
- sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
- sed -i 's|/model/Brother|/model|g' $_wrapper_source
- sed -i 's|lpinfo|echo|g' $_wrapper_source
- export srcdir=$srcdir
- ./$_wrapper_source
- sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
- sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
- rm $_wrapper_source
- fi
+ # Patch cupswrapper script
+ sed -i '/^sleep/d' ${_cupswrapper}
+ sed -i '/^echo lpadmin/d' ${_cupswrapper}
+ sed -i '/^lpadmin/d' ${_cupswrapper}
+ sed -i "s|/usr|${srcdir}/usr|g" ${_cupswrapper}
+ sed -i "s|/opt|${srcdir}/opt|g" ${_cupswrapper}
+ sed -i "s|/model/Brother|/model|g" ${_cupswrapper}
+ sed -i 's|lpinfo|echo|g' ${_cupswrapper}
- # /etc/printcap is managed by cups
- rm `find $srcdir -type f -name 'setupPrintcap*'`
+ # Invoke cupswrapper script
+ export srcdir=${srcdir}
+ ./${_cupswrapper}
- # /usr/lib/cups/filter/brother_lpdwrapper_ql720nw should be an absolute symlink
- rm $srcdir/usr/lib/cups/filter/brother_lpdwrapper_ql720nw
- ln -s /opt/brother/PTouch/ql720nw/cupswrapper/brother_lpdwrapper_ql720nw \
- $srcdir/usr/lib/cups/filter/brother_lpdwrapper_ql720nw
-}
+ # Patch resulting filter
+ sed -i "s|${srcdir}||" ${srcdir}/usr/lib/cups/filter/*lpdwrapper*
-package() {
- cd "$srcdir"
+ # Remove cupswrapper script and templates
+ find "${srcdir}" -type d -name 'cupswrapper' -exec rm -rf {} +
- cp -R usr $pkgdir
- if [ -d opt ]; then cp -R opt $pkgdir; fi
+ # Remove unneeded script (i.e. /etc/printcap is managed by CUPS)
+ rm $(find "${srcdir}" -type f -name 'setupPrintcap*')
- install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # Remove binaries for different architectures
+ if [ "${CARCH}" = 'x86_64' ]; then
+ find "${srcdir}" -type d -name 'i686' -exec rm -rf {} +
+ elif [ "${CARCH}" = 'i686' ]; then
+ find "${srcdir}" -type d -name 'x86_64' -exec rm -rf {} +
+ fi
}
+package()
+{
+ # Install actual content
+ cp -R "${srcdir}/usr" "${pkgdir}"
+ cp -R "${srcdir}/opt" "${pkgdir}"
+
+ # Handle license
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ find "${pkgdir}" -type f -name 'LICENSE*.txt' -exec mv -t "${pkgdir}/usr/share/licenses/${pkgname}" {} +
+}