summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2017-11-17 10:52:39 +0100
committerKarol Babioch2017-11-17 10:52:39 +0100
commit9632ce64f223f74f3dbe77dfa5bd2609123c4e71 (patch)
tree99d5de34626fb1620560c1c0c61670c9cab8d4ef /PKGBUILD
downloadaur-9632ce64f223f74f3dbe77dfa5bd2609123c4e71.tar.gz
Initial commit of version 1.1.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..052f58db3ed7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+# Inspired by package brother-dcp130c
+
+pkgname='brother-ql820nwb'
+pkgver=1.1.4r0
+pkgrel=1
+pkgdesc='LPR and CUPS driver for Brother QL-820NWB label printer'
+url='http://solutions.brother.com/linux/en_us/'
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('cups')
+if [ "$CARCH" = 'x86_64' ]; then
+ depends+=('lib32-glibc')
+fi
+install="$pkgname.install"
+source=("http://download.brother.com/welcome/dlfp100344/ql820nwblpr-${pkgver/r/-}.i386.rpm"
+ "http://download.brother.com/welcome/dlfp100346/ql820nwbcupswrapper-${pkgver/r/-}.i386.rpm"
+ 'LICENSE')
+sha256sums=('512edabbac5563805b387cabfe1dbed506947d87c6d40375c0afaca9473a5880'
+ 'd2134f1aaa0bd923a2142c153d136b4dd053b07613c39865a008b5667e3060c6'
+ 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+
+prepare()
+{
+ # do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+
+ # setup cups directories
+ install -d "$srcdir/usr/share/cups/model"
+ install -d "$srcdir/usr/lib/cups/filter"
+
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^echo lpadmin/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+
+package() {
+ cd "$srcdir"
+
+ cp -R usr $pkgdir
+ if [ -d opt ]; then cp -R opt $pkgdir; fi
+
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+