summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarol Babioch2016-09-16 10:52:20 +0200
committerKarol Babioch2016-09-16 10:52:20 +0200
commitcef1be94f334440fe8b18920b2f336673c12365d (patch)
tree9477afda2c3fa3ec6f7f75d82ba8099adec3c390 /PKGBUILD
downloadaur-cef1be94f334440fe8b18920b2f336673c12365d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1882efd796f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+# Inspired by package brother-dcp130c
+
+pkgname='brother-td2020'
+pkgver=1.0.1
+pkgrel=0
+pkgdesc='LPR and CUPS driver for Brother TD-2020 label printer'
+url='http://solutions.brother.com/linux/en_us/'
+arch=('i686' 'x86_64')
+license=('custom')
+depends='cups'
+if [ "$CARCH" = 'x86_64' ]; then
+ depends+=('lib32-glibc')
+fi
+install="$pkgname.install"
+source=("http://download.brother.com/welcome/dlfp002209/td2020lpr-$pkgver-$pkgrel.i386.rpm"
+ "http://download.brother.com/welcome/dlfp002211/td2020cupswrapper-$pkgver-$pkgrel.i386.rpm"
+ 'LICENSE')
+sha256sums=('0612f7642304bb4cdd2a4e8d32f7abcfe9259e833e24fca4cb1374004f4d142c'
+ '19bfcca9eec05712c68d4d2012c997e747851d85bc0fe9a5c51b7224aadcf4a7'
+ 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+
+prepare()
+{
+ # do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+
+ # setup cups directories
+ install -d "$srcdir/usr/share/cups/model"
+ install -d "$srcdir/usr/lib/cups/filter"
+
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^echo lpadmin/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+
+package() {
+ cd "$srcdir"
+
+ cp -R usr $pkgdir
+ if [ -d opt ]; then cp -R opt $pkgdir; fi
+
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+