summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredchenjs2019-06-21 13:28:34 +0800
committerredchenjs2019-06-21 13:28:34 +0800
commit0d3680c953c7c1e3c639dbecba78a05a9f0b7a31 (patch)
tree680d08216c704593503947387ae47d6a6c1788dc /PKGBUILD
downloadaur-0d3680c953c7c1e3c639dbecba78a05a9f0b7a31.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac277a381f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jack Chen <redchenjs@live.com>
+
+pkgname=browser360
+pkgver=10.0.2001.0
+pkgrel=2
+pkgdesc="A chromium based web browser from Qihoo 360"
+arch=('x86_64')
+url="https://browser.360.cn/se/"
+license=('custom')
+depends=(
+ 'ca-certificates'
+ 'ttf-liberation'
+ 'gconf'
+ 'libappindicator-gtk3'
+ 'gconf'
+ 'gtk2'
+ 'nss'
+ 'libxss'
+ 'lsb-release'
+ 'wget'
+ 'xdg-utils'
+)
+source=(
+ 'ftp://zyiot.top/pub/aur/browser360-cn-stable_10.0.2001.0-2_amd64.deb'
+)
+md5sums=(
+ 'cd23bd055b040cb055907288e4623ddc'
+)
+
+package() {
+ cd "${srcdir}"
+ tar -xf data.tar.xz -C "${pkgdir}"
+ # remove cron
+ rm -rf "${pkgdir}"/etc
+ # install icons
+ for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
+ install -Dm644 "${pkgdir}"/opt/browser360/product_logo_${i/x*}.png \
+ "${pkgdir}"/usr/share/icons/hicolor/$i/apps/${pkgname}.png
+ done
+ rm "${pkgdir}"/opt/browser360/product_logo_*
+}