summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Meunier2018-11-23 22:22:43 +0100
committerGuillaume Meunier2018-11-23 22:22:43 +0100
commit5cda6406b8031044658448b23a5011e3174aa7ee (patch)
tree52b3e99e55bf1749bf565bbfbb29c38aa01e5a77 /PKGBUILD
parentc8888a92c84001f459c1d11a3e35253387d63a4a (diff)
downloadaur-5cda6406b8031044658448b23a5011e3174aa7ee.tar.gz
Use upstream URL
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a61e019913c0..77f13c833b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=(bsf-git bsf-git-docs)
pkgbase=bsf-git
_pkgname=bsf
-pkgver=r4575.54f5a3abc
+pkgver=r4583.852c0abe4
pkgrel=1
epoch=
pkgdesc="A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools"
@@ -10,27 +10,25 @@ arch=(x86_64)
url="https://www.bsframework.io/"
license=('MIT')
groups=()
-depends=(libutil-linux libx11 icu libxcursor libxrandr libxi libgl openal flac libvorbis snappy freeimage freetype2)
makedepends=(git cmake doxygen ninja)
checkdepends=()
optdepends=()
-provides=(bsf)
-conflicts=(bsf)
-replaces=()
+conflicts=()
backup=()
options=()
install=
changelog=
-# source=("git+https://github.com/GameFoundry/bsf.git"
-source=("git+https://github.com/Meumeu/bsf.git#branch=build-system-cleanup"
+source=("git+https://github.com/GameFoundry/bsf.git"
"install-dir.patch"
+ "build-system.patch"
"https://data.banshee3d.com/bsfCompiledData_Master_5.zip"
"https://data.banshee3d.com/bsfData_Master_6.zip"
"https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip")
noextract=()
sha256sums=('SKIP'
'3ebcebdbe4d5bad832a47109b09f6d9bcd3e02b7a0bb9be2301c8bd630ed706b'
+ '1fda65aeb00578833a17a4347a6abb4062c44f48beccd3c83d762c29a9abb7b3'
'49b419403f4f85e189832f3b89c78c037e7b531541bb67b130764f33c7306224'
'3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025'
'60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036')
@@ -49,6 +47,7 @@ prepare() {
rm -rf "$_pkgname"/Dependencies/freetype
rm -rf "$_pkgname"/Dependencies/freeimg
+ patch -d bsf -p1 < build-system.patch
patch -d bsf -p1 < install-dir.patch
}
@@ -63,6 +62,8 @@ pkgver() {
}
build() {
+
+
mkdir -p "$_pkgname"/build
cd "$_pkgname"/build
@@ -74,6 +75,11 @@ build() {
}
package_bsf-git() {
+ provides=(bsf)
+ replaces=(bsf)
+ depends=(libutil-linux libx11 icu libxcursor libxrandr libxi libgl openal flac libvorbis snappy freeimage freetype2)
+ arch=(x86_64)
+
pushd "$_pkgname"/build
DESTDIR="$pkgdir"/ ninja install
popd > /dev/null
@@ -85,7 +91,6 @@ package_bsf-git() {
}
package_bsf-git-docs() {
- depends=()
arch=(any)
mkdir -p "$pkgdir"/usr/share/doc/$pkgbase