summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Meunier2018-12-07 18:04:22 +0100
committerGuillaume Meunier2018-12-07 18:04:22 +0100
commitdce02480cce391d74d84d43ac3144ff5fb612766 (patch)
tree3af7052183ee80861d986b36859089f771d43958 /PKGBUILD
parentfade03e3febc5c1952766b468ffa98ab1ecf6207 (diff)
downloadaur-dce02480cce391d74d84d43ac3144ff5fb612766.tar.gz
Don't strip debug symbols in CMakeLists
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 826d2aa442aa..d23180cb1433 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=(bsf-git bsf-git-docs)
pkgbase=bsf-git
_pkgname=bsf
-pkgver=r4602.b5807447c
+pkgver=r4615.c46bcf338
pkgrel=1
epoch=
pkgdesc="A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools"
@@ -19,22 +19,27 @@ options=()
install=
changelog=
-source=("git+https://github.com/GameFoundry/bsf.git"
- "install-dir.patch"
- "https://data.banshee3d.com/bsfCompiledData_Master_5.zip"
- "https://data.banshee3d.com/bsfData_Master_6.zip"
- "https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip")
+source=('git+https://github.com/GameFoundry/bsf.git'
+ 'install-dir.patch'
+ 'dont-strip-symbols.patch'
+ 'https://data.banshee3d.com/bsfCompiledData_Master_5.zip'
+ 'https://data.banshee3d.com/bsfData_Master_6.zip'
+ 'https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip'
+ 'https://data.banshee3d.com/bsfDocImagesData_Master_2.zip')
noextract=()
sha256sums=('SKIP'
- '3ebcebdbe4d5bad832a47109b09f6d9bcd3e02b7a0bb9be2301c8bd630ed706b'
+ 'ee326f6eb0a97e7b306181a34675b5fadf55ce69bdec1c738600bb9d15908e91'
+ '68c27be79da735c7aa2cdc30558d30b73a61eb6d52d00d4b0bd085c9fc96fc87'
'49b419403f4f85e189832f3b89c78c037e7b531541bb67b130764f33c7306224'
'3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025'
- '60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036')
+ '60c53790eda57495fefdad2bcc4a6a78198a330e70aeec71abc213edcc8b7036'
+ 'e9d3793f87c4ff0a36f3574ecd070e4b6b25c567a063e3042d2dc5883636f011')
validpgpkeys=()
prepare() {
cp -r Data bsf/
cp -r Dependencies bsf/
+ cp -r Documentation bsf/
cp -r Raw bsf/Data
rm -rf "$_pkgname"/Dependencies/OpenAL
@@ -46,6 +51,7 @@ prepare() {
rm -rf "$_pkgname"/Dependencies/freeimg
patch -d bsf -p1 < install-dir.patch
+ patch -d bsf -p1 < dont-strip-symbols.patch
}
pkgver() {