summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatheus2022-11-06 16:49:36 +0100
committerMatheus2022-11-06 16:49:36 +0100
commit61f35350b1766a2549edf2b81c942ea14c698f5c (patch)
tree2d50e0acdd7bee8ee4ce229590c70b99bc14bd4e /PKGBUILD
parentc511ab80bf5e5eb802b32eee5cd3a5837a10d82e (diff)
downloadaur-61f35350b1766a2549edf2b81c942ea14c698f5c.tar.gz
Huge revision.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf5cd4701764..b18edfe9a8db 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
#!/usr/bin/env bash
# shellcheck disable=SC2034
# shellcheck disable=SC2154
-# Maintainer: Matheus Gabriel Werny de Lima <matheusgwdl@protonmail.com>
+# The PKGBUILD for BTCPayServer.
+# Maintainer: Matheus <matheusgwdl@protonmail.com>
+# Contributor: Matheus <matheusgwdl@protonmai.com>
pkgname="btcpayserver"
pkgver="1.6.12"
pkgrel="1"
pkgdesc="Accept Bitcoin payments. Free, open-source and self-hosted Bitcoin payment processor."
-arch=("any")
+arch=("x86_64")
url="https://github.com/btcpayserver/${pkgname}"
license=("MIT")
-depends=("aspnet-runtime" "bitcoin-daemon" "dotnet-sdk" "nbxplorer")
+depends=("bash" "aspnet-runtime" "bitcoin-daemon" "dotnet-sdk" "lib32-glibc" "nbxplorer")
optdepends=("apache: HTTP server"
"core-lightning: Lightning network support"
"certbot: Creates SSL certificates."
@@ -20,8 +22,11 @@ optdepends=("apache: HTTP server"
"nginx: HTTP server"
"postgresql: Database"
"sqlite: Database")
-source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=("4f4457867b36057faecbbc4e65ec8f3e34a09919f07d7629d633e2b1a7faf1cfbe92b95503099148d3547106049c8b0df7d379169e5163470cbb5fbdf18624f4")
+install="${pkgname}.install"
+source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ "${pkgname}.sh")
+sha512sums=("4f4457867b36057faecbbc4e65ec8f3e34a09919f07d7629d633e2b1a7faf1cfbe92b95503099148d3547106049c8b0df7d379169e5163470cbb5fbdf18624f4"
+ "c9f310e4373f6889a71d5158974c96972efff2141fac448ae1897d0653c7053dc28a8701be44eae6300b69eebc8c6d9f370b5d51598962195fd39d593119f3bf")
build()
{
@@ -38,21 +43,15 @@ package()
# Install the software.
cp -r "${srcdir}"/"${pkgname}"-"${pkgver}"/* "${pkgdir}"/usr/share/webapps/"${pkgname}"/
-
- ## Create an executable.
- echo -e "#!/usr/bin/env bash
-
-dotnet run --no-launch-profile --no-build -c Release --project /usr/share/webapps/\"${pkgname}\"/BTCPayServer/BTCPayServer.csproj -- \"\${@}\"" > "${pkgdir}"/usr/bin/"${pkgname}"
- chmod 755 "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm755 "${srcdir}"/"${pkgname}".sh "${pkgdir}"/usr/bin/"${pkgname}"
# Install the documentation.
install -Dm644 "${srcdir}"/"${pkgname}"-"${pkgver}"/README.md "${pkgdir}"/usr/share/doc/"${pkgname}"/
cp -r "${srcdir}"/"${pkgname}"-"${pkgver}"/docs/* "${pkgdir}"/usr/share/doc/"${pkgname}"/
- chmod -R 644 "${pkgdir}"/usr/share/doc/"${pkgname}"/
+ find "${pkgdir}"/usr/share/doc/"${pkgname}"/ -type d -exec chmod 755 {} +
+ find "${pkgdir}"/usr/share/doc/"${pkgname}"/ -type f -exec chmod 644 {} +
# Install the license.
install -Dm644 "${srcdir}"/"${pkgname}"-"${pkgver}"/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/
-
- # Information
- echo -e "\033[0;32mConfiguration is needed after the installation. For assistance, read the included \"README.md\".\033[0m"
+ find "${pkgdir}"/usr/share/licenses/"${pkgname}"/ -type f -exec chmod 644 {} +
}