summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVladislav Nepogodin2024-01-03 16:44:27 +0400
committerVladislav Nepogodin2024-01-03 16:44:27 +0400
commit97a402f991d236cc6fceace173add853aab5a44b (patch)
tree4040e9a35939f60508c0191a5f725a7dac6aeb38 /PKGBUILD
parent3f5a7e1721430912de1ac53cd5e831917da4597e (diff)
downloadaur-97a402f991d236cc6fceace173add853aab5a44b.tar.gz
👷 add GPU support, remove submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 10 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74524f107a63..57eeea1366e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Vladislav Nepogodin <nepogodin.vlad@gmail.com>
pkgname=btop-git
-pkgver=1.2.13.r772.0267eba
+pkgver=1.3.0.r896.3567254
pkgrel=1
pkgdesc="A monitor of resources"
-arch=(any)
+arch=(x86_64)
url="https://github.com/aristocratos/btop"
license=('Apache-2.0')
+depends=('gcc-libs')
makedepends=('gcc' 'make' 'git')
-source=("${pkgname}::git+https://github.com/aristocratos/btop.git"
- "git+https://github.com/fmtlib/fmt.git")
-sha512sums=('SKIP'
- 'SKIP')
+optdepends=(
+ 'nvidia-utils: NVIDIA GPU support'
+ 'rocm-smi-lib: AMD GPU support'
+)
+source=("${pkgname}::git+https://github.com/aristocratos/btop.git")
+sha512sums=('SKIP')
provides=('btop')
conflicts=('btop')
-options=(!strip)
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -23,18 +25,10 @@ pkgver() {
printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
-
- git submodule init
- git config submodule."lib/fmt".url "${srcdir}/fmt"
- git -c protocol.file.allow=always submodule update
-}
-
build() {
cd "${pkgname}"
- make STATIC=true
+ make GPU_SUPPORT=true RSMI_STATIC=false
}
package() {