diff options
author | willemw12 | 2023-10-15 21:32:34 +0200 |
---|---|---|
committer | willemw12 | 2023-10-15 21:32:34 +0200 |
commit | 1ee3fb80df63d537c1499a1e6c95e4c83e94eec0 (patch) | |
tree | 04d4ac7bf090f6878de5b00cd70f8b0287ef06d0 /PKGBUILD | |
parent | c61ef4fff4d768da9731f0fb55517fb8a701bb50 (diff) | |
download | aur-1ee3fb80df63d537c1499a1e6c95e4c83e94eec0.tar.gz |
Use Rust's stable toolchain in prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -2,13 +2,13 @@ pkgname=btrfs-backup-git pkgver=0.2.1.r0.g02aea34 -pkgrel=1 +pkgrel=2 pkgdesc='Backup and restore Btrfs subvolumes' arch=(x86_64) url=https://github.com/d-e-s-o/btrfs-backup license=(GPL3) makedepends=(cargo git) -depends=(btrfs-progs ) +depends=(btrfs-progs) provides=("${pkgname%-git}") conflicts=("${pkgname%-git}") source=("$pkgname::git+$url.git") @@ -19,8 +19,8 @@ pkgver() { } prepare() { - #cargo fetch --locked --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu" - cargo fetch --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu" + #RUSTUP_TOOLCHAIN=stable cargo fetch --locked --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu" + RUSTUP_TOOLCHAIN=stable cargo fetch --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu" } build() { @@ -32,5 +32,5 @@ build() { #} package() { - install -Dm0755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin" + install -Dm755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin" } |