summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien Dubosson2015-05-29 13:15:13 +0200
committerFabien Dubosson2015-05-29 13:15:13 +0200
commit4e018080424fc7fcdf92aab6f2126e73c7c2a4d9 (patch)
tree86020837de8d3446f6b2daf5d0790af638ab1304 /PKGBUILD
downloadaur-4e018080424fc7fcdf92aab6f2126e73c7c2a4d9.tar.gz
Move 'budgetwarrior-git' into separate repo for AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c46af319c538
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Fabien Dubosson <fabien.dubosson@gmail.com>
+
+pkgname="budgetwarrior-git"
+_pkgname="budgetwarrior"
+pkgver=0.4.1.1.r5.g13de1b0
+pkgrel=1
+pkgdesc="Simple command line utility to helps keeping track of your expenses and the state of your budget."
+url="https://github.com/wichtounet/budgetwarrior"
+license=('MIT')
+arch=('i686' 'x86_64')
+makedepends=('git' 'cmake' 'clang')
+depends=('boost' 'util-linux')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+changelog="ChangeLog"
+source=("${_pkgname}::git+https://github.com/wichtounet/${_pkgname}#branch=develop")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}/"
+
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}/"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/"
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/man/man3"
+ install -d "${pkgdir}/usr/share/zsh/site-functions/"
+ install -d "${pkgdir}/etc/bash_completion.d"
+ make prefix="${pkgdir}/usr" install
+}
+
+# vim:set ts=4 sw=4 et: