summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoria Keung2022-04-21 15:13:13 -0400
committerDoria Keung2022-04-21 15:13:13 -0400
commit4cf5c8dd22b3c862e42cd9e405de41bea8cd74d6 (patch)
treeb15de7d43dd90cab3c19e6d5f466029e2a7b811d /PKGBUILD
parent1875c942b455d029e40c850f7a24df7489d3d923 (diff)
downloadaur-4cf5c8dd22b3c862e42cd9e405de41bea8cd74d6.tar.gz
Update to v1.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dfd2b6437da..9f76ae720475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Buf <bot@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.3.1.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.4.0.tar.gz")
build() {
- cd ${pkgname}-1.3.1
+ cd ${pkgname}-1.4.0
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf completion bash >completion.bash
./buf completion zsh >completion.zsh
@@ -21,13 +21,13 @@ build() {
}
package() {
- install -Dm755 "${pkgname}-1.3.1/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.3.1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.3.1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.3.1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.3.1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
- install -Dm644 "${pkgname}-1.3.1/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
- install -Dm644 "${pkgname}-1.3.1/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm755 "${pkgname}-1.4.0/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.4.0/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.4.0/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.4.0/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.4.0/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm644 "${pkgname}-1.4.0/completion.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/buf.fish"
+ install -Dm644 "${pkgname}-1.4.0/manpages/${pkgname}"* -t "${pkgdir}/usr/share/man/man1/"
}
-sha256sums=('a45297153349f800756c7e07ba1c9198a82f870c9c740b1c0538321130950266')
+sha256sums=('7815a1c4182d2ede5a135ee296e9100d6e929ffdf58a9ab46fc6c15c3d07e815')